WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] How can I turn off comments? (9 posts)

  1. wisedave
    Member
    Posted 1 year ago #

    [EVENTS MANAGER]

    Hello,

    I keep getting spam comments on my events. Is there a way to turn off comments for this plug in?

    Cheers,

    Dave

    http://wordpress.org/extend/plugins/events-manager/

  2. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    Hi Dave,

    Yes, there's to thing you need to do:

    1. You need to edit previous events to disable comments (e..g you can bulk edit them), because disabling comments entirely in WP doesn't mean previous posts/events with comments get disabled

    2. Events > Settings > Pages > Event Pages > Enable Comments = No - which prevents future events from having comments.

  3. wisedave
    Member
    Posted 1 year ago #

    Hey Marcus,

    I have that already set but still seem to get comments.

    Is there a way to check this at 'event' level? For example, can I go into each event a tick a box of some sort?

    Cheers,

    Dave

  4. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    Yes, that's what I mean by point 1. In a single event, you'd be looking for the discussion meta box (if you don't see it, go to the screen options tab ont he top right of the page).

  5. wisedave
    Member
    Posted 1 year ago #

    I still don't see that....sorry Marcus.

    I made a SCREENR video so you can see what I'm looking at.

    http://www.screenr.com/h0e7

    Any thoughts or am I just smoking my lunch and don't see it.

    Cheers,

    Dave

  6. Thijsonline
    Member
    Posted 1 year ago #

    Do you have "Allow people to post comments on new articles" unchecked under Settings > Discussion?

    Checking that should provide you with the option you're looking for.

  7. wisedave
    Member
    Posted 1 year ago #

    That is unchecked......

  8. Thijsonline
    Member
    Posted 1 year ago #

    Ok, then presumably you need to turn that on first in order to get the functionality to turn it off on page/post level. Curious to hear if that helped.

  9. caimin_nwl
    NetWebLogic Support
    Posted 1 year ago #

    I'd try what Thijsonline is suggesting.

    In your video, it looked to me like the Discussion option was missing from the Screen Options panel at the top.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic