WordPress.org

Ready to get started?Download WordPress

Forums

How can I recreate posts with albums in WP? (9 posts)

  1. bill.unger
    Member
    Posted 6 years ago #

    I have been using Movable Type and some custom coding to create slick personal blog with integrated images. In an attempt to streamline my process flow and having played around a bit with WordPress, I think I am ready to make the leap from MT to WP. Unfortunately, I am not able to recreate the same functionality in WP. Here is my current site: http://www.billunger.com

    Does anyone know how I can emulate the same format with a thumbnail single image on the main page which links to thumbnails of the full album completely integrated into the post?

    Thanks in advance for any thoughts or suggestions!
    Bill

  2. bill.unger
    Member
    Posted 6 years ago #

    anyone... bueller... bueller... bueller :-)

  3. jarinteractive
    Member
    Posted 6 years ago #

    Try my PhotoJAR plugins. Grab both of them from here: http://wordpress.org/extend/plugins/profile/jarinteractive. You can see some examples on my blog (My images link to LightBox, but it can be set to link to the full post as well).

    -James
    Plugins::Website/Blog

  4. bill.unger
    Member
    Posted 6 years ago #

    James,

    That is awesome and may be exactly what I was looking for. I have downloaded, installed, and tested the plugin and have two questions that will hopefully "seal the deal!"

    1. Is it possible to change the image link on the main page (ie., index.php) from the image that is displayed to a link to the related post?

    2. I have set the thumbnail size to 50x50, which is accurately reflecting on the main page; however, when I view the gallery in the post itself all of the images are full size and I can't seem to get them to resize. Any thoughts? Also... any thoughts on how I might be able better organize the gallery images on the post page?

    By the way, the example can be seen under the Kitchen Remodeling post at http://test.billunger.com

    Thanks again and excellent work!
    Bill

  5. bill.unger
    Member
    Posted 6 years ago #

    James,

    Ignore that second question - I figured it out. I had a size parameter in the gallery shortcode that was frying it for some reason. After removing the size parm, everything is dandy for question 2. I am still curious about question 1, though... :-)

    And I would like to add one more question: is it possible to center the main page thumbnail and then have the post text below the image? I tried centering and using some html tags, but they get ignored...

    thanks again,
    Bill

  6. jarinteractive
    Member
    Posted 6 years ago #

    Bill,

    I'm glad you are enjoying the plugins. You can link the image to the post by changing the "Link Post Thumbnail To" setting on the PhotoJAR settings page (set it to "Post Permalink"). You can edit default-theme.php in the plugin directory to change the positioning of the thumbnail. Make sure you back up your changes, as that file will be overwritten when the plugin is updated. I will be improving the theming in future revisions. Hope this is helpful!

    -James
    Plugins::Website/Blog

  7. bill.unger
    Member
    Posted 6 years ago #

    James,

    Thanks again for the help and two more questions... :-)

    I do have the "Link Post Thumbnail To" setting set to "Post Permalink" but no go. Any thoughts?

    Do you take donations? :-)

    thanks again,
    Bill

  8. jarinteractive
    Member
    Posted 6 years ago #

    Bill,

    You found a bug. :-) I updated Post Thumbnailer with a fix. Remember to back up your custom default-theme.php before you update.

    I have added a Paypal donation button to the PhotoJAR page if you would like to make a donation.

    Thanks for putting up with my bugs and helping to improve PhotoJAR!

    -James

  9. bill.unger
    Member
    Posted 5 years ago #

    James,

    I may have found one more bug:

    Specifically, if I upload an image to a post that has the same file name as a different image associated with a different post, the correct image does not display in the thumbnail (for the single post or the gallery). Here is an example:

    http://billunger.com/2007/06/27/summer-washin/

    Click on the image of the kitchen - it is 1.jpg - when you click it, the correct image ( my son ) displays....

    Any thoughts?

    Thanks again!
    Bill

Topic Closed

This topic has been closed to new replies.

About this Topic