WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How can I override "blog" directory for permalinks? (3 posts)

  1. cazm
    Member
    Posted 4 years ago #

    I have a site cazphoto.co.uk which had an old blog installed on it at "cazphoto.co.uk/blog". I tried installing a new version (with 3 multisite) as a blog(site) but was told this directory was reserved, so had to choose "photoblog" instead. It works fine. But in order to maintain old permalinks, I've had to put rewrite rules in the old /blog/ directory .htaccess file:

    (snippet)
    RewriteBase /blog/
    RewriteRule 20(.*)$ /photoblog/20$1 [R,L]

    This also works fine (I don't have posts older than 2007), for the new installation of photoblog - permalinks are working/redirecting as expected.

    OK, now back to the ROOT site. I want to have a NEWS section there (perfect to make with posts from the "root" blog/site). But I can't make the permalink structure cazphoto.co.uk/news/postpermalink - it's forcing me to use cazphoto.co.uk/blog/postpermalink which of course breaks - because it's being redirected to the cazphoto.co.uk/photoblog/postpermalink where the post does not exist!

    In the admin screen for the root site, I can set a custom permalink structure - but only BELOW the "blog" directory. How can I change this to "news" instead?

    At the moment, I can't see any way around this. Either my new "news" permalinks will be broken or my old "blog" permalinks will be broken :-(

    Any advice appreciated, thanks!

  2. The root blog (main-site etc) actually uses the /blog subfolder, which is why /blog/ is restricted. You CAN change it, mind you: http://wordpress.org/support/topic/398291?replies=12

    If you install 3.0 MS in the root of your site (cazphoto.co.uk), then the default URL for blog pages will actually be cazphoto.co.uk/blog/permalinkfoo

    You'd have to make a site called 'News' to use cazphoto.co.uk/news

    Unraveling that would be a trial. You should have a main 'site' with the permalink of /blog/ and I think my first step would be to change THAT to /news/ and see if that works.

  3. cazm
    Member
    Posted 4 years ago #

    Thanks @Ipstenu - hadn't seen that setting in the Superadmin folder. All sorted out now, knew there should be a fix somewhere!

Topic Closed

This topic has been closed to new replies.

About this Topic