WordPress.org

Ready to get started?Download WordPress

Forums

Host will not send e-mails from Nobody (7 posts)

  1. cdorr
    Member
    Posted 8 years ago #

    When someone leaves a comment it will not reach me (I have this option turned on in the Options area). Although 2 comments have reached me. I checked with my Hosting provider and they tell me that they will not send anything out that has Nobody as the sender. So I went looking into the code it looks like (but hell if I know) the system does not send as nobody. Same thing goes for when a user creates an account. What file can I find the respective mail functions in or what can I change to make it a generic e-mail address to see if that works? I've looked at wp-mail.php, wp-includes/pluggable-functions.php and those don't seem to do the trick.

    Latest WordPress version 1.5.2

    Thanks,
    chris d.

  2. Monika
    Member
    Posted 8 years ago #

    cdorr
    I have the same problem and first I thought it was the plugin wp contact form,
    but I can't find anything. :-(
    a bug ?

    kindly regards
    Monika

  3. skippy
    Member
    Posted 8 years ago #

    You might want to try using wp PHPmailer. It lets you specify the sender, and allows PHP to use real SMTP, instead of the local mail() application.

  4. cdorr
    Member
    Posted 8 years ago #

    Skippy,

    I tried that one already (on a previous post) and was not able to get it to work! I even specified the from address and still no luck. I'll give it a try again later tonight and see if it works.

  5. Monika
    Member
    Posted 8 years ago #

    I'm using wp_PHPMailer - it doesn't work for me.
    I've tried everything and I have to realize it doesn't work since I've upgrated to the new version of wp.
    So I have to use a workaround - with an old simple email script of mine, because I go on leave for two weeks. ;-)

    kindly regards
    Monika

  6. cdorr
    Member
    Posted 8 years ago #

    Monika,

    If you don't mind what did you end up doing? I'd love to see it. I'm going to play around with the PHPMailer stuff and see if it works (I don't think it will!)

  7. Fanatyk
    Member
    Posted 7 years ago #

    I've got the same problem. I got 2 WP blogs on the same host: tox.pl one is in domain fanatyk.eu and the second is in default subdomain pawel.tox.pl.
    On fanatyk.eu e-mails arived properly but pn the second blog I reive no emails after recive comments.

    Any ideas why?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags