WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
horizontal thimbnails and timthumb (5 posts)

  1. neuville
    Member
    Posted 7 months ago #

    hello, I'm trying to use the horizontal thumbnail template to work with timthumb, but the thumbnails are all messed up.

    Looking into the code the output looks the same of the default thumbnail (all the divs are in the same place).

    what am I doing wrong?

    http://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 7 months ago #

    I'll need more details because "all messed up" could mean a lot of things. Can you provide a link to a sample? Thanks.

  3. neuville
    Member
    Posted 7 months ago #

    ok, you're right and my fault... forgive me.
    I cannot post a link because I'm working locally using easyphp.

    the code I'm using is a modified verion of the example template; code follows:

    <?php
    /*
    YARPP Template: Thumbnails 2
    Description: Requires a theme which supports post thumbnails
    Author: A wordpress author
    */ ?>
    <h3>Related Ads</h3>
    <?php if (have_posts()):?>
    <div class="yarpp-thumbnails-horizontal">
    <?php while (have_posts()) : the_post(); ?>
    		<a class="yarpp-thumbnail" href="<?php the_permalink() ?>" title="<?php the_title(); ?>">
    		<span class="yarpp-thumbnail-default">
    		<?php if( get_post_meta($post->ID, "thumbnail",  true) ): ?>
    		<img src="<?php bloginfo('url'); ?>/scripts/timthumb.php?src=<?php echo get_post_meta($post->ID, "thumbnail", $single = true); ?>&h=120&w=120&zc=1" alt="<?php the_title(); ?>" width="120" height="120" />
    		<?php else: ?>
    		<img width="120" height="120" src="<?php bloginfo('url'); ?>/scripts/timthumb.php?src=<?php echo catch_that_image() ?>&h=120&w=120&zc=1" />
    		<?php endif; ?>
    		</span>
    		<span class="yarpp-thumbnail-title"><?php the_title(); ?></span>
    		</a>
    
    	<?php endwhile; ?>
    	</div>
    
    <?php else: ?>
    <p>No related photos.</p>
    <?php endif; ?>

    this is the output

    this one is when using the built in function: no thumbnails, but correct css...

    thanks sorry again for my fault

  4. jeffparker
    Member
    Plugin Author

    Posted 7 months ago #

    So is your issue resolved then?

    Also, would you mind telling me how you first heard about YARPP, using this very short survey? http://www.surveymonkey.com/s/Z278L88

    Thanks much!

  5. neuville
    Member
    Posted 6 months ago #

    hello jeff,
    no unfortunately I did not solve the issue (didn't have much time to spend over my theme)

    yes, I'll take the survey as soon as possible; forgive me in advance if I'll contact you again (I'm currently updating the plugin to latest version)

Reply

You must log in to post.

About this Plugin

About this Topic