WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Home.php not taking. (2 posts)

  1. Doodlebee
    Member
    Posted 4 years ago #

    I can't figure out why this isn't taking. (WordPress is being a bear for me today - I think it hates me for some reason right now LOL)

    Running a site in a development server/localhost. I have about 15 WP sites on my dev server, all of them running 2.8.4, and all of them but *this* one is doing what it's supposed to be doing.

    In my Settings, I have permalinks set to /%category%/%postname%, no plugins are installed yet (this is a fresh one), and I have a few Pages inserted as content with one titled "Intro" set as the static home page in my settings.

    In my theme files, I've created a "home.php" file that will have a different layout than any other page on the site. Typically, that's all I need to do.

    However the "home.php" file is being completely and utterly ignored.

    Steps I've tried to resolve this:

    1) switching to default. home.php is still ignored (I copied "index.php", and at the top of index.php I wrote "index.php"; at the top of "page.php" I typed in "page.php"; and at the top of home.php, I typed "home.php" so I could see which file was being pulled - every time - even in the default theme - "page.php" is being pulled. Home is completely overlooked. Because this is happening with a fresh install, no plugins and the default theme, I know it's not *my* theme or any plugins that's causing this.)

    2) Deleting the files completely and totally, and putting in a fresh new installation of 2.8.4.

    3) Changing the slug of my "intro" page from "intro" to "home".

    4) changing the title of my "intro" page to "home".

    5) adding in " /* Template Name: Home */" to the top of my home.php file.

    6) Deleting the intro page and choosing a different page as the home page.

    Nothing. home.php is ignored in all cases.

    Does *anyone* know what might be the cause of this? Some weird setting I'm not seeing? Usually it doesn't do this - and now it is. I have a bunch of other themes (on different installations) that do the same thing and are working just fine. I'm at a complete loss here. Any tips on where I could look to fix this would be appreciated.

    Thanks!

  2. Doodlebee
    Member
    Posted 4 years ago #

    Gah. nevermind. Apparenty after adding the "Template Name:Home" stuff, the new template showed up in a dropdown. Typically I don't need to do that - but when I chose the "home" template, it took. (It'd be nice to know if something changed though - i dont' remember even having to do that before.)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.