WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] homepage wiped when pointing url to subdirectory (4 posts)

  1. mintslice
    Member
    Posted 2 years ago #

    Hi there,

    Now that my wordpress site is ready to go live, I wish to redirect my URL to the new wordpress site. Both my soon-to-be-replaced website and my current wordpress website have their own subdirectories in my root dir.
    While following the "Using a pre-existing subdirectory install" instructions from
    Giving_WordPress_Its_Own_Directory I have made a mistake somewhere. I had managed to get my url to point to my wordpress site, but the homepage was missing and displayed the theme's custom "...the page you requested could not be found..." message. The theme is displaying fine, and the other links on the home page work, it's just the home page's actual content that is missing.

    I have tried to restore as much as I can on mycP but I'm pretty sure I've deleted something pretty important, the problem is, I have no idea which file it was. As it is, the URL now points back to the cruddy old site, and when I use the .com.au/wordpress link, the home page for my wordpress site is still missing.

    Can someone please suggest a solution without having to reload all the original wordpress files and starting from scratch?

  2. mintslice
    Member
    Posted 2 years ago #

    Further information:

    I got as far as step 6. in the documentation
    "Change the following and save the file. Change the line that says:
    require('./wp-blog-header.php');
    to the following, using your directory name for the WordPress core files:
    require('./wordpress/wp-blog-header.php')"

    The cruddy website I have been asked to update: http://www.nealesvenson.com.au

    The missing home page: http://www.nealesvenson.com.au/wordpress/

    The theme is Feast
    Crazydomains is their host

    Hope that helps. Thanks heaps.

  3. webadmin@montereycoastprep.org
    Member
    Posted 1 year ago #

    After we got done moving our /wordpress directory up, we had this problem and solved it by replacing the index.php file with one that looked like this:

    <?php
    header( 'Location: http://www.yoursite.com/new_page.html' ) ;
    ?>
    See http://php.about.com/od/learnphp/ht/phpredirection.htm for more details but between the redirect above and this:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    we were good to go!
    - Jay

  4. lowercasesarah
    Member
    Posted 1 year ago #

    Hi,

    I am having this problem too, but Jay's solution didn't work for me.

    I have notice that after I go through the process of "using a pre-existing subdirectory install":

    • the home page doesn't load
    • the theme loads
    • all pages except the home page load
    • BUT trying to go to the home page always redirects the URL to the subdirectory, whilst viewing other pages does not feature the subdirectory in the URL

    Any ideas?

    I am using the Responsive theme.

Topic Closed

This topic has been closed to new replies.

About this Topic