WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] HomePage Redirect Problem (10 posts)

  1. jkurzner
    Member
    Posted 1 year ago #

    Have read through tons of problems related to my issue, but none of them have resolved the problem. My site works just fine from the default root of my website at nbcobt.org except for the home page. All the links work properly and the admin panel workds fine. However, the root page does not come up and shows an error of "This webpage has a redirect loop". I have disabled all plugins. reverted to the 2012 theme and yet the problem persists. I am using the /%category%/%postname%/ for permalinks. I tried the fix canonical plugin and that did not resolve the problem either.

    I've been staring at the thing for hours now and would love some assistance.

  2. graphical_force
    Member
    Posted 1 year ago #

  3. jkurzner
    Member
    Posted 1 year ago #

    Yes, I forgot to mention that I already cleared my cache and removed cookies. The redirect loop happens in all browsers. The site is at http://www.nbcobt.org As far as permissions, folders appear to have 755 and files 664.

  4. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Can you change what the home page is set to at settings>Reading>Front page displays?

  5. graphical_force
    Member
    Posted 1 year ago #

  6. jkurzner
    Member
    Posted 1 year ago #

    Hi Seacoast, Yes, I tried changing the home page to a different page and it just makes the new page generate the same error, but the original front page works fine.

    graphical_force I did try the disable-canonical-redirects.php plug-in (or what I could find of it) and that did not solve the problem. I don't have the WPML plugin installed. Presently all plugins are disabled.

  7. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    For each of the pages tested as front page, what is the selected page template? Is that template broken, missing?

    Your home page seems down now...if you can login, switch to default unedited theme with all plugins deactivated while you troubleshoot the issue with the theme in use...create a new page to set as home page for now and add only typed in text in the editor to it - do not copy and paste...

  8. jkurzner
    Member
    Posted 1 year ago #

    Hey Seacoast. Created new test page with only text. Set the template to default and the same thing happens. I have to believe it has something to do with the htaccess or index.php, etc. or hosting providers setup. I also tried a re-install of 3.5.1 and that didn't help I've looked at all the permissions. Any other ideas? I'm not a great php or apache guru so this has me a bit stumped.

  9. graphical_force
    Member
    Posted 1 year ago #

    Check the htaccess and see what it looks like. Here is some info on permalinks and htaccess. http://codex.wordpress.org/Using_Permalinks

  10. jkurzner
    Member
    Posted 1 year ago #

    Problem solved. The website was originally setup with Network solutions and they will not let you set it up into the root directory when you install opensource applications using the website tools. After installation, I moved the site to the root. However, network solutions must maintain a different htaccess file in a physical location that I don't have access to. There was an option in the open source applications to remove the website (still showing the initial installed directory) from the home page and voila!

Topic Closed

This topic has been closed to new replies.

About this Topic