WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Homepage link doubles language URL (redirects to itself), creating 404 (3 posts)

  1. oldschoolashell
    Member
    Posted 4 months ago #

    Hello,
    thanks for the terrific plugin!

    I’m terribly sorry if this has been resolved, but all the posts I could find are either too technical (I only have HTML and CSS basics – no PHP), or not quite pertaining to the problem.

    I’m running the Crush theme and everything is working beautifully, except when I click on the home link at the top. The home link links the to same language, i.e. http://mydomain.de/de, but causes the language redirection to activate itself again. http://mydomain.de/de/de and gives me a 404.

    My page: http://joshuamarr.de

    Languages: German and English (de & en)

    Activated options:
    · The language is set from the directory name in pretty permalinks
    · Remove /language/ in pretty permalinks
    · The front page url contains the language code instead of the page name or page id
    · When the front page is visited, set the language according to the browser preference
    · Activate languages and translations for media
    · All other checkboxes for "portfolio" and "synchronization" are activated

    I’ve tried changing many of the options to see what’s causing it, but so far, no luck. I would be grateful if could help!

    https://wordpress.org/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 4 months ago #

    Please download the current development version. It should fix the problem.
    http://downloads.wordpress.org/plugin/polylang.zip

  3. oldschoolashell
    Member
    Posted 4 months ago #

    Great! Thank you! When will the development version be officially released as an update? I’ve currently circumvented the problem by setting the language from content and still have some time left before my page goes "public."

Reply

You must log in to post.

About this Plugin

About this Topic