WordPress.org

Ready to get started?Download WordPress

Forums

Homepage Images not appearing (6 posts)

  1. ricland
    Member
    Posted 4 years ago #

    My homepage images are not appearing on homepage. However, they appear in the read-more section.

    This is a recent occurance. For over two years I haven't had this problem.

    I've read the fix, but adding instructions to the "excerpt" section of each post is not realistic. I have hundreds of post. I'd be doing this forever.

    Here's the site: http://basinfarmer.com/

  2. Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that doesn't resolve the issue, switch to the Default theme temporarily. Do the images appear correctly?

  3. ricland
    Member
    Posted 4 years ago #

    Yeah, the images appear correctly with the default theme.

    I'm thinking I should reload the theme and I will, just as long as that won't hurt my existing articles and images.

    Will it?

  4. No, it won't. If that doesn't fix it, your theme is probably using the_excerpt instead of the_content on the index template. Find something like this:

    <?php the_excerpt(); ?>

    and replace it with something like this:

    <?php the_content(); ?>

  5. ricland
    Member
    Posted 4 years ago #

    Thanks, but all my index file has is

    <?php /* This is how it looks like ;)*/ ?>

    My question is why after two years it suddenly chucks all the images on the front page.

    Any theory on that?

  6. I have no clue, but it does appear to be theme-specific as it worked when you switched back to the Default. It's hard to tell without access to the theme files.

Topic Closed

This topic has been closed to new replies.

About this Topic