WordPress.org

Ready to get started?Download WordPress

Forums

Homepage Blank - index.php and all internal pages fine - HELP!! (4 posts)

  1. kma9090
    Member
    Posted 5 years ago #

    Hello,

    I have perhaps the most annoying problem... ever and I don't know how to sort it. I have been trying for weeks. Hopefully someone here can help me out.

    My website which has always worked fine has run into one major problem since moving to my new webhost.

    If you go to my website http://www.domain.com

    The page is blank, the website doesn't show. No error messages, just nothing.

    However,

    If I go to http://www.domain.com/index.php the site displays fine. As does wp-admin and all internal pages, posts and categories. It's only if someone types my domain in directly it doesn't work.

    I don't currently have a .htaccess file but I did try one that was supposed to redirect to index.php. This didn't work ( I think because the page wasn't loading in the first place).
    I also tried uploading a index.htm page and putting a redirect code in, this didn't work either.

    The weird thing is, If I use a webspider to see what the search engines see, everything looks fine.

    Has anyone ever experienced anything like this and can anyone help, seriously. I am tearing my hair out here.

  2. ClaytonJames
    Member
    Posted 5 years ago #

    run into one major problem since moving to my new webhost.

    See if this thread leads to anything helpful.

  3. kma9090
    Member
    Posted 5 years ago #

    Hi again, I followed that link but it didn't really help. If anyone else has any ideas I would be really appreciative.

  4. Hotcoffee
    Member
    Posted 4 years ago #

    Did you ever end up fixing this? I have the same problem with my windows hosting... everything was working perfectly when I had it set up on a subdomain...

    Let me know if you found an easy solution. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic