WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Home Page Title and Meta Description Option missing (12 posts)

  1. Ashraf
    Member
    Posted 7 months ago #

    Hi there, I am using WP 3.8 and latest version of WordPress SEO by Yoast (v- 1.4.22 Compatible up to: 3.8) but there is no Home page Title and Meta Description Option.
    I have changed theme, uninstalled other plugins, but still there is same problem. Can any one help me please ? Is this a bug ?

    visit this link to see screenshot

    http://wordpress.org/plugins/wordpress-seo/

  2. SodaBicarbona
    Member
    Posted 7 months ago #

    SAME problem

  3. appsfinder
    Member
    Posted 7 months ago #

    me too :(

  4. conservativeread
    Member
    Posted 7 months ago #

    bug in wp 3.8 should reinstall 3.8 to fix clear cache

  5. appsfinder
    Member
    Posted 7 months ago #

    done that still the same :(

  6. VYSUAL
    Member
    Posted 7 months ago #

    same issue here. Interested for a fix.

  7. jrf
    Member
    Posted 7 months ago #

    This is not a bug. You are using a page as the frontpage.
    I know reading is difficult, but just as it says on the page of which you made a screenshot: you can change the title and meta description in the page itself. The page even provides you with links to the homepage where you can change it.

    Please mark this topic as resolved.

  8. VYSUAL
    Member
    Posted 7 months ago #

    Duh jrf. Do you think we're all idiots ?
    If there's this topic is because the meta description field doesn't display on the page editor...

  9. jrf
    Member
    Posted 7 months ago #

    Vysual, that's not what the original question says... am I supposed to read minds ?

    Do you not see the WPSEO Metabox at all when you edit pages ?

    Few things you can check, start by going to the edit page for your homepage:

    1. Do you see the WPSEO Metabox header, just not the content: try expanding it.. I know it seems obvious, but too often that's all it is.
    2. Do you see the WPSEO Metabox header, just not the content and trying to expand does not help ? Have a look at the javascript console to see if there are any errors in scripts and have those fixed.
    3. If you don't see the WPSEO Metabox header at all when you edit the front page - open up screen settings (tab in the top right of the screen) and see if the box in front of WPSEO is checked.
    4. If you don't see the WPSEO Metabox header when you edit the front page and you don't see the tickbox when you open up screen settings, go to WPSEO -> Titles and Meta -> Post Types tab and make sure the tickbox for "WPSEO Meta Box - hide" is unchecked for pages.

    Now if none of those suggestions helped, then and only then, you may have the right to 'duh' me...

    And no, I don't think you're *all* idiots, though inexperienced users who ask without searching for an answer first, who ask without reading instructions and who demand support for free software *does* describe a lot of people on these forums in general....

  10. VYSUAL
    Member
    Posted 6 months ago #

    "I know reading is difficult[...]" didn't appear to be very constructive mindset ;)

    Indeed for me it was 3 and 4. Thanks a lot man, I un-duh you

  11. jrf
    Member
    Posted 6 months ago #

    Apology accepted ;-) P.S.: I'm not a man.

  12. bagwellmkt
    Member
    Posted 6 months ago #

    I have the same issue. I am using WordPress with Genesis. When I loaded Youst SEO I do not have an SEO link Under Genesis anymore.
    I can not figure out how to add the Page title and description for my home page, which is the default Genesis for the theme --not an actual Page built out. I've looked all over for that. It will probably be obvious once someone points that out, but for now I am baffled.

Reply

You must log in to post.

About this Plugin

About this Topic