WordPress.org

Ready to get started?Download WordPress

Forums

Busiprof
[resolved] [closed] Home page template (7 posts)

  1. mrgreenwaters
    Member
    Posted 7 months ago #

    Hi, I'm trying to make a custom home page template. But the theme index.php file is overriding my home-page.php template file. Why?

  2. alchymyth
    Forum Moderator
    Posted 7 months ago #

  3. mrgreenwaters
    Member
    Posted 7 months ago #

    Yes, I did that already. Have you tried it?

    *Edit - please try to make your own home page template using this theme.

  4. alchymyth
    Forum Moderator
    Posted 7 months ago #

    custom home page template

    like a static front page?
    or for posts?

    what file name are you using for the home page template?

    according to the Codex chapter front-page.php or home.php would be the default file.

    I just see, the theme already has a front-page.php - you might need to customise that, or create a home.php - please re-review the linked Codex chapter.

  5. mrgreenwaters
    Member
    Posted 7 months ago #

    alchymyth you are a genius!!!

    The theme does have a front-page.php file. This prevents me from adding any custom home template. I made a home-page.php template, but wordpress doesn't see it.

    This is the first time I run across a theme that uses front-page.php. I've never had issues creating a custom template before. Learn something new everyday.

    Thanks!

  6. rayleiter
    Member
    Posted 1 month ago #

    I have a custom church website running via wp on my laptop and my server.
    They used to work the same. Recently, I needed to make changes to the prod. site, so I began with my laptop and got things working the way I wanted (it still does-using 'wamp' in Win7 HP SP1). When I finished with the changes on the laptop and moved them to the server, for awhile, it worked! Now the server doesn't work the same. I have a static front page called 'homepage.php' which works on the laptop but, on the server, wp insists on running 'page.php' or if that isn't available, it runs 'index.php'! I can't figure out why it runs 'homepage.php', as it should, on the laptop, but instead runs 'page.php' on the server. I even copied all the '.php' files from the laptop to the server, thinking that would solve it -- NO LUCK! IS IT A CONFIGURATION ISSUE OR WHAT?

  7. Andrew
    Forum Moderator
    Posted 1 month ago #

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.