WordPress.org

Ready to get started?Download WordPress

Forums

Home Page Randomly Forwarding to a Page (16 posts)

  1. nabusman
    Member
    Posted 4 years ago #

    I have a blog, hosted on my own domain which has been working fine for awhile now (almost two years now). I was creating a new page as an opt-in page for adding subscribers. I added the HTML code from Aweber into the page, excluded the page from the header. As far as I know that is all I have done in terms of changes. But now my homepage (which was previously my latest posts) is forwarding to this new subscribe page instead of showing my posts. My database is intact since all my posts are available if i go to the urls directly. I checked my .htaccess file which looks fine (I don't really know how to use them, but I've seen them before and it looks fine, let me know if you need me to paste it in here). I tried undoing everything, including deleting the page but that gives a 401 error. Apparently, I screwed up somewhere in the code, but I don't understand how, its not that easy to randomly forward your homepage... at least not in my knowledge. any help or ideas appreciated.

    P.S.: I have everything updated to the latest and greatest including plugins...

    Thanks,

    Nabs

  2. nabusman
    Member
    Posted 4 years ago #

    another thing, under Reading Settings, "Your Latest Posts" is still selected.

  3. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you checked the "Front page displays" section in Settings/Reading?

  4. nabusman
    Member
    Posted 4 years ago #

    #esmi, Yeah it still says "Your Latest Posts"

  5. mybusinessmarketing
    Member
    Posted 4 years ago #

    I am having the same issue this is the third today. I think theres something going on... http://mybusinessmarketing.org it is being redirected to a page I created yesterday.

  6. berchman
    Member
    Posted 4 years ago #

    FWIW, I too am experiencing this auto-forward phenomena.

    WordPress 3.0

  7. sboerup
    Member
    Posted 4 years ago #

    Yes, I created a new page this morning. It was a random test page for new video content. Now whenever I go to my homepage, it redirects to this new page. I trashed and deleted the page, but it still redirects to the new page.

    I logged into phpmyadmin and everything still looks fine, so please help if you know the solution!

  8. sboerup
    Member
    Posted 4 years ago #

    A quick solution was to add a redirect on my domain to a new page that clones the main homepage, but, its only a workaround. Sounds like there is a new WordPress update that is changing the mySQL database info . . .

  9. llclj
    Member
    Posted 4 years ago #

    I had the exact same issue. I tried unpublishing the new page and then I got a 404 error. I went into the plugin settings and under the group "modified posts" the plugin had added some new redirects. I deleted them and all is fine.

    So i voted it is broken.

    But I wasted an hour fooling with it. :(

  10. jesussanchez
    Member
    Posted 4 years ago #

    Hello. I also having the same problem. It started about two hours ago. I had published a page instead of a post by accident. Now entering the home page forwards you to a different portion of the site (I've included the links below). I deleted the page and checked and made sure the settings have not changed. They have not.

    Links from menu bars and to individual posts work fine. Any help is appreciated since I have little WordPress experience.

    Homepage URL:
    http://www.theEastsiderLA.com

    Where you end up:
    http://www.theeastsiderla.com/2010/04/save-the-date-weekend-edition-10/

    I'm also on WordPress 3.0 with using a Thesis theme.

  11. jesussanchez
    Member
    Posted 4 years ago #

    Hi, llclj. I checked the plugin settings but could not find the "modified posts" plug in you describe. Anyone else have some suggestions?

  12. llclj
    Member
    Posted 4 years ago #

    I found it under "groups".

  13. Stephanie Leary
    Member
    Posted 4 years ago #

    I've now had this problem on several 3.0 sites: when a single page is set as the home page, the home page starts redirecting to some random other page. Deactivating Redirection solves the problem. I can't find any combination of settings that makes it work in 3.0, alas.

  14. ericdaams
    Member
    Posted 4 years ago #

    I found a fix for this bug. Disabling Redirection works, but I needed Redirection to be active, so if you're in the same boat, here's what you need to do. Unfortunately you'll need to do some editing of the plugin files, as well as some fiddling in your database:

    1. The redirection problem is occurring because the plugin created a redirect when you first hit save or publish on the post/page. This means there is a row in your database that you need to remove. So either through phpMyAdmin or your favourite SQL client, log into your database and find the wp_redirection_items table (it will be wp_2_redirection_items if you're using the Multi-User option). Under the 'url' column, find the one that just has '/' (or if you're on MU, it will be something like '/blog'). Delete that row.

    2. Try going to your front page. It shouldn't redirect anymore. If it does, then something went wrong in step 1 above.

    3. Assuming it's not redirecting anymore, here's how you prevent this from happening again whenever you write a new post or page. Either through FTP or the back-end plugin editor in WP, go to redirection/models/monitor.php.

    4. Find the following:

    function insert_old_post ()
    	{
    		global $post;
    	?>
    	<input type="hidden" name="redirection_slug" value="<?php the_permalink () ?>"/>
    	<input type="hidden" name="redirection_status" value="<?php echo $post->post_status ?>"/>
    	<?php
    	}

    5. Change it to:

    function insert_old_post ()
    	{
    		global $post;
    
    		if ( $post->post_status != 'auto-draft' ) {
    	?>
    	<input type="hidden" name="redirection_slug" value="<?php the_permalink () ?>"/>
    	<input type="hidden" name="redirection_status" value="<?php echo $post->post_status ?>"/>
    	<?php }
    	}

    6. Save the file. The plugin is now fixed.

    If you need a hand with any of this, or want me to do it for you, you can get in touch through my site's contact form: http://ericnicolaas.com/contact/

    Cheers,
    Eric

  15. jesussanchez
    Member
    Posted 4 years ago #

    Hello. The person who helped me set up my WordPress blog found solution here:

    http://wpveda.com/solved-homepage-redirecting-to-the-latest-page/

  16. thinkweb
    Member
    Posted 4 years ago #

    Thank you jesussanchez for the link! It seems to have fixed the problem for me.

Topic Closed

This topic has been closed to new replies.

About this Topic