WordPress.org

Ready to get started?Download WordPress

Forums

  1. Walter479
    Member
    Posted 1 year ago #

    How can restrict NextGen icons for sharing (Fb, Twitter etc.) to be on my Home page only, and not show up on the following pages after that? That's the only page I want it on anyways. Any ideas? ( http://www.apureway.com )

    http://wordpress.org/extend/plugins/nextgen-facebook/

  2. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Oh, that's a new one. :) Hm.

    First, how are you adding the buttons? To the content using the "Enable" check boxes on the settings page, shortcode, widget, a call to the ngfb_get_social_buttons() function?

    Thanks,

    js.

  3. Walter479
    Member
    Posted 1 year ago #

    Thru the Settings menu - which is all I know.

  4. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Looking at your HTML, it looks like you're using Post ID #4 as your main / static home page. You could probably do something like this in your CSS:

    .ngfb-content-buttons {
      display:none;
    }
    #post-4 .ngfb-content-buttons {
      display:block;
    }

    js.

  5. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Or... You could uncheck all the buttons and use a shortcode in your (Post #4) content instead. See the Other Notes tab for more info on using the shortcode: http://wordpress.org/extend/plugins/nextgen-facebook/other_notes/

    js.

  6. Walter479
    Member
    Posted 1 year ago #

    I'm new to website building - financial restrictions keep from hiring someone to do this - and I don't understand a lot of the lingo so I look for menu driven in simple language plugins as much as possible. I did uncheck all the buttons and enabled the shortcode on the new version after updating it - any way to make it appear on just the home page only? That's the only page I want anyone to be able to 'like' or refer too - not to jump past the previous pages. Thanks again.

  7. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Walter,

    Looking at the HTML source of your home page, it looks like you're using Page ID #4 as your home page content, correct?

    Edit Post ID #4 and add the following to your content text:

    [ngfb buttons="facebook, gplus, linkedin, pinterest, stumbleupon, tumblr, twitter"]

    js.

  8. Walter479
    Member
    Posted 1 year ago #

    I think it is the 'Page ID #4' that is tripping me up - I don't understand what that is. I'm just using WordPress and the Plugins - I'm sure once I figure out what you are referring to I can edit it - as I know I could copy/paste the string you gave me once I figure what I need to edit or take out first. Sorry for the hassle.

  9. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Hm.

    Well, looking at your HTML source, it looks like you defined Page ID #4 as your static home page (Settings -> Reading -> Front page displays). Edit whatever Page you selected there.

    js.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic