WordPress.org

Ready to get started?Download WordPress

Forums

Home page issues with https (5 posts)

  1. Bet Hannon
    Member
    Posted 3 months ago #

    I have installed an SSL (and checked with my host to make sure that it's installed correctly) and set the WordPress Address (URL) and the Site Address (URL) to include HTTPS.

    When the domain name is simply typed into the browser address bar, the homepage displays as HTTP. If I click to an interior page of the site, it displays a HTTPS, and if I go back to the homepage from that page, the homepage displays with a HTTPS.

    (For a while, going back to the https homepage in Chrome was breaking the display. I'm not sure exactly what I did to fix that, but that problem seems to be solved.)

    Is this what I should be expecting? I thought if I reset the WordPress Address and the Site Address under Settings--General, that the entire site should always – every page and post – display in HTTPS.

  2. missybunnie
    Member
    Posted 3 months ago #

    It sounds like the homepage being http vs https is a matter of how the dns is resolving or redirecting which I think would be set by your host. But it does sound like you have everything on the WordPress end set up correctly.

  3. tasko
    Member
    Posted 3 months ago #

    Did you try to force it through wp-config.php?
    define('WP_HOME','https://www.example.com');
    define('WP_SITEURL','https://www.example.com');

  4. Bet Hannon
    Member
    Posted 3 months ago #

    tasko, I hadn't seen this option before, and was sure it would help, but it didn't.

    I tried both with & without www, and cleared caches...

    It does seem weird that I have put all these settings in place to "force" https on the site, and every page BUT the home page uses https.

  5. Bet Hannon
    Member
    Posted 3 months ago #

    Just in case anyone else comes along with this issue, here is how I solved it:

    The plugin WordPress HTTPS deals with a number of SSL issues. I found this in it's FAQ:
    "... you can use URL Filters in the WordPress HTTPS Settings to secure your entire site by putting just '/' as a filter. This will cause any URL with a forward slash to be secure (all of them)."

    Putting that "/" in the HTTPS Settings made the home page (and every other page of the site) display in https.

Reply

You must log in to post.

About this Topic