WordPress.org

Ready to get started?Download WordPress

Forums

Home Page issue (20 posts)

  1. Kamilabat
    Member
    Posted 2 years ago #

    When you go to my blog http://www.bellebebeblog.com you see a Home page and the page looks fine but when you start browsing the blog, for example go to Furniture and then when you want to go back to that Home page, you see category archives/ Home and even at the bottom it says where it was posted. So it's like it's not taking you back to that primary domain but it's taking you to a post in a category/archives. I was told that I have the Home link pointing to a directory /category/home/, rather than the primary directory, /public_html. How can I change it?

  2. theotherlebowski
    Member
    Posted 2 years ago #

    you've set home as a category and included it in your menu. if you go to Appearance -> Menus and remove the home link from your menu, save your menu and then go to the Custom Links box and add in the full URL of your site's homepage with nothing after the .com, give it the label home then add it to your menu. move it into place and then save the menu.

    head back to your site and refresh it in the browser and navigate about a bit and see if that helps...

  3. Kamilabat
    Member
    Posted 2 years ago #

    I did exactly what you told me to do but it's not working.

  4. Caroline Moore
    Member
    Posted 2 years ago #

    If you go to Posts -> Categories, do you have a category named Home? If so, try renaming its slug to something like home-2. It's possible you have a page called Home and a category called Home, both with the same slug, and WordPress is getting them confused.

    Otherwise you might have better luck posting this in How-to and Troubleshooting since this isn't a theme problem.

  5. Kamilabat
    Member
    Posted 2 years ago #

    Caroline- changing it to Home 2 is not working either. I posted the same message in How-to and Troubleshooting but they told me to contact the theme developer, because it might be something within a theme. Nobody knows how to fix it.

  6. theotherlebowski
    Member
    Posted 2 years ago #

    just thought, in Settings -> Reading what do you have set as your front page? if you have a static page defined then you can choose the Home Page and it will defailt back to that otherwise if you're just using it as is it will automatically assume you want blog posts to appear on your homepage and default back to the home category. try that and see if it makes a difference...

  7. Caroline Moore
    Member
    Posted 2 years ago #

    Did you set up a custom menu under Appearance -> Menus? It's possible you dragged the Home Category into the menu instead of the Home Page.

    I say this because the menu would display only your Pages by default if not configured under Appearance -> Menus. You're linking to Categories in the menu, so at some point a custom menu was created an assigned to that navigation area.

    If you click the site title, it goes to the appropriate place. So I don't think it's a permalinks problem, but a configuration error with the menus.

  8. Kamilabat
    Member
    Posted 2 years ago #

    theotherlebowski- your first suggestion is working! I just realized I removed the home link from Pages and not categories, that's why it wasn't working. Thank you.
    One more question. When you click on any of my categories, for example you go to Furniture- it says Category archives:Furniture, instead of just Furniture, is there a way I can change that too?

  9. Kamilabat
    Member
    Posted 2 years ago #

    Caroline I wish somebody could go to my dashboard and check all the settings because I'm sure I set something wrong, but for now, if you read the message above, it's fixed.
    Thank you very much

  10. Kamilabat
    Member
    Posted 2 years ago #

    Caroline, since you're here I have one more question related to the patchwork theme. I have a logo that I'm going to use on that blog but I don't know how to get rid of the frame that's within the theme? or if I wanted to get rid of the patchwork image completely and make it the tan color that is used in the background, is it possible too?

  11. theotherlebowski
    Member
    Posted 2 years ago #

    for your theme you'll need to go into the file called archive.php and remove a little bit of text. look for this line

    printf( __( 'Category Archives: %s', 'patchwork' ), '<span>' . single_cat_title( '', false ) . '</span>' );

    delete where it says Category Archives and then save your changes. head back to your main site, hit refresh and see what happens :)

  12. Kamilabat
    Member
    Posted 2 years ago #

    theotherlebowski-Where do I find archive.php? Where is that file?

  13. Kamilabat
    Member
    Posted 2 years ago #

    theotherlebowski- do I delete that whole line or just category Archives?

  14. theotherlebowski
    Member
    Posted 2 years ago #

    you need to go into Themes -> Editor and on the right you'll find a dropdown list of the installed themes, select patchworka dn then look down the list of files to find Archive. select it and only delete the two words Category Archive in that line of code only! save the file and then go back to the main site and select a category and see if it's disappered :D

  15. Caroline Moore
    Member
    Posted 2 years ago #

    Before you make changes to the theme files, I highly recommend making changes in a child theme instead, so your edits are preserved across theme updates. Also, if you make a mistake, it's easier to reverse it quickly rather than potentially having to install the theme and start from scratch.

    You can use CSS to change just about anything in the theme--like the header frame's border or the background image. I haven't tested this code but it should give you an idea:

    header#masthead {
    background-image: none;
    }
    
    header#masthead hgroup {
    background-color: transparent;
    border: 0px none;
    }
  16. Kamilabat
    Member
    Posted 2 years ago #

    I know I'm stupid about all this, but yes it disappeared, thank you very much. I have to remember your name so if I have any questions I will ask you :) Thank you!!!

  17. theotherlebowski
    Member
    Posted 2 years ago #

    i agree about child themes but that's a whole extra layer of headwrecking if you're new to the whole thing. Kamilabat if you drop me a private message i'll create a child theme for you and you can work on that later but if you just want to test out whether deleting that bit of the line works then carry on with that and then you know it works and can sort it in the child theme later.

  18. Kamilabat
    Member
    Posted 2 years ago #

    Oh boy, I don't know what you guys are talking about and that's my problem :) I'm still waiting for the logo so I can't try anything just yet. theotherlebowski- if you could help me with that i would be very grateful. Do you have any email address i could use to keep in touch?

  19. theotherlebowski
    Member
    Posted 2 years ago #

    drop me a line at jackrandall@justtheriffs.com

  20. Kamilabat
    Member
    Posted 2 years ago #

    Ok thank you very much to both of you

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags