WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Home page is using page.php instead of home.php. Argh. (3 posts)

  1. JoshRenaud
    Member
    Posted 2 years ago #

    So I've set up a WordPress site and am using the Reaction theme. The problem I'm having doesn't have to do with the theme, though, I think. In the Reading settings, I've set it to use a static page as the front page and specified the Home page for it. The identical setting exists in the Reaction customize settings and I've done the same thing there.

    I know for a fact it is using page.php and not home.php because I put some unique text to display in each one and only the text I added to page.php is displaying when I go to the front page of the site. Furthermore, I did a test using is_front_page() and it IS seeing it as the front page! I'm completely stumped and frustrated because this is a simple thing that should be working, but it's not. Please make my week and point out what the heck I'm missing. I'll love you for it!

  2. JoshRenaud
    Member
    Posted 2 years ago #

    Oops. The Home page was using the Default template. Setting it to use the Home template got things working correctly.

  3. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Look at:

    Admin Dashboard>Pages>All Pages>Hover over the page title of the page you set to home page>quick edit>what template is listed as in use and what others are available to use?

    Also, see Page Templates...with this, one can create their own page template and set that one in above (based on your preferred template).

Topic Closed

This topic has been closed to new replies.

About this Topic