WordPress.org

Ready to get started?Download WordPress

Forums

Amdhas
[resolved] Home page appearance (19 posts)

  1. hannahsigmon
    Member
    Posted 10 months ago #

    This feels like it should be easy, so maybe I'm maybe missing something obvious. I'm helping someone build a website, and initially it was in a blog format with a non-static homepage. Now he wants it to be a regular website format with a static homepage and he wants the homepage to look like the Homepage Default style for this theme. I've switched everything over and designated the home page and I have the default style selected in Theme Options, but his home page still has the style of one of the subpages, and I'm not sure how to fix that. Any suggestions? Thanks!!

  2. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    Without a link to the site to see what you are talking about, pretty hard to be of much help.

  3. hannahsigmon
    Member
    Posted 10 months ago #

    Well, since it's his site, I need to talk to him before I start posting links on forums. But when you look at the default home page style for the Amdhas theme, there's a welcome message area on the top left, a heading with a site description and button on the top right, and three widget home areas underneath. Then when you look at a subpage, there is just the page title with some text area and no widget areas underneath. I need his home page to look like that default style, but it doesn't, it looks like the subpage style. It also says Home > Home at the top, like it would say Home > Parent Page or something, so I think it's not really being recognized as the home page, I just can't figure out why.

  4. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    I'm not familiar with this theme but just installed it on a test site.

    What's selected for the home page under Settings > Reading?

    IS there any caching on the site? Have you cleared your browser cache?

  5. hannahsigmon
    Member
    Posted 10 months ago #

    The selected home page is "Home," the one I want to display that default style. I hadn't tried clearing my cache, but I just did and it's no different.

  6. hannahsigmon
    Member
    Posted 10 months ago #

    And the slug for my home page is home-2, and I can't change it to just say home, so maybe that's a clue?

  7. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    That usually means there is another page by the same name in the trash - try emptying the trash.

  8. hannahsigmon
    Member
    Posted 10 months ago #

    Yeah, I just did that. No change.

  9. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    I'm not sure I can be of more help without seeing the site.

  10. hannahsigmon
    Member
    Posted 10 months ago #

    This is the site: http://italkrealestate.com/

    Notice how it looks just like the format of the other pages. And if you preview the Amdhas theme here, http://wordpress.org/themes/amdhas, that's what it should look like.

  11. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    I just fooled around with it a bit more and it looks like you need to select "latest posts" under the Settings > Reading to get the default home page option.

  12. hannahsigmon
    Member
    Posted 10 months ago #

    Okay...that's good, but is that going to cause any functional issues since it won't be a static page? He's not intending this to be a blog, the home page content isn't supposed to change.

  13. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    It is a static page - it's just the way that theme is set up. That page should not change unless it's changed under the theme options.

  14. hannahsigmon
    Member
    Posted 10 months ago #

    It looks like I would just have to delete my home page entirely, because that page isn't pulling from the page I made titled "Home" anymore.

  15. hannahsigmon
    Member
    Posted 10 months ago #

    Okay, so it's just a quirk with this theme?

  16. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    Yes, looks like that's how the theme works - but you can add that content to the home page options.

  17. hannahsigmon
    Member
    Posted 10 months ago #

    I don't think I ever would have figured that out. Thanks so much!!!

  18. hannahsigmon
    Member
    Posted 10 months ago #

    Hopefully should be fine now.

  19. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    You're welcome :).

Reply

You must log in to post.

About this Theme

About this Topic