WordPress.org

Ready to get started?Download WordPress

Forums

Home link after moving blog (12 posts)

  1. dsol828
    Member
    Posted 3 years ago #

    I recently had to move my blog to a new host/domain.
    I've successfully moved the entire DB and files and the blog is up and running.

    My issue is that the "Home" link in the menu still leads to my OLD domain.

    Both links in the "General Settings" are correct (my new domain).
    For no real reason, I'm guessing this is an issue with my theme not getting the domain change.

    I'm using Magazine Basic as a theme.
    Can anyone shed some light on this?

    Thanks in advance!

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems?

  3. dsol828
    Member
    Posted 3 years ago #

    Just tried both.
    Deactivating ALL plugins did not change the link.
    Also switching to Twenty Ten did not change the link.

    Also forgot to mention in OP, the banner link is correct, just the home button in the menu.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Check that the home link isn't hard coded in header.php.

  5. dsol828
    Member
    Posted 3 years ago #

    doesn't appear in either the theme header.php or wp-blog-header.php

    The fact that the problem remains even with other themes means its not theme related right?

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Yes.

    Did you follow the instructions in Moving_WordPress?

  7. dsol828
    Member
    Posted 3 years ago #

    For the most part, I followed the "moving wordpress to a New Server".

    However, in my database backup/dump, I hadn't changed the "home" and "siteurl" yet. So after restoring the backup on the new hosting, I changed them directly in the database with phpmyadmin (which is "option 2" under "If you forget to change the locations").

  8. dsol828
    Member
    Posted 3 years ago #

    bump...

    No one has any fresh ideas here huh?

    I'm guessing the issue is in the database since a quick look through most of the PHP's (theme and WP) have turned up little.

    Anyone know where else this link might show up other than the "siteurl" and "home" fields?

  9. santosh.sahoo
    Member
    Posted 3 years ago #

    change the home,siteurl in option table to ur new home url...

  10. dsol828
    Member
    Posted 3 years ago #

    I already changed those two fields directly in the database and they appear correctly in the general setting on wp-admin.

    Still showing the old link.

  11. jerbear31
    Member
    Posted 2 years ago #

    Did you figure out how to resolve this issue? I'm encountering the same problem

  12. PaoloCatalan
    Member
    Posted 2 years ago #

    Same issue here. I read the Changing The Site URL with no avail. I also checked Settings > General WordPress and Site URL. Any fix?

Topic Closed

This topic has been closed to new replies.

About this Topic