WordPress.org

Ready to get started?Download WordPress

Forums

Highlight Search Terms plugin does not highlight non-english content (10 posts)

  1. Tara
    Member
    Posted 2 years ago #

    I have been testing this plugin on and off for a while.

    It works fine for English content.

    But it does not highlight non-english content in the posts. Any solution for this problem? Thanks a lot.

    I use the default Twenty Ten theme.

  2. RavanH
    Member
    Posted 2 years ago #

    That's funny. The jQuery script is designed to recognize character sequences without regard to spelling or language... Do you have a link to an example where non-english text is not highlighted?

  3. Tara
    Member
    Posted 2 years ago #

    Thanks Ravan for your reply.

    Yours is a nice, lightweight plugin. I started looking into it since WP version 2.85, but never could use it because although it nicely highlights the English text but not the non-english text.

    I even tried the non-plugin hack of this, but the same exact problem.

    Obviously there is something wrong at my end. But then I also wonder, if there is a problem at my end, why it then even highlights the English text!

    Whatever is causing this glitch, I am unable to figure it out.

  4. RavanH
    Member
    Posted 2 years ago #

    Is your site completely non-english or is it a mixture of multiple languages? If the latter, are you using a plugin like qTranslate or WPML for that?

    A link would really help...

  5. Tara
    Member
    Posted 2 years ago #

    Thanks Ravan for your respose:

    All post are predominantly in English with some content in the posts in non-english.

    1. English content is highlighted brilliantly.
    2. it is the non-english content not highlighted, eventhough the search terms are found by the search, but not highlighted.

    I have tried different computers, and different browsers (IE9, FF4, chrome, etc.). Mystery remains unresolved.

    Thanks again for your time and help.

  6. RavanH
    Member
    Posted 2 years ago #

    I tested on one of my multi-lingual websites but it works fine there. However, these languages are both western languages using UTF8.

    What second language are we talking about in your case? If it's a completely different character set (like for Chinese or other) than maybe that is the problem...

    Again, a link would really help.

  7. RavanH
    Member
    Posted 2 years ago #

    ...Oh, this testing I did with the new development version which you can download here, but I doubt if that makes any difference...

  8. Tara
    Member
    Posted 2 years ago #

    What second language are we talking about in your case?

    Indic (Indian).

    In wp-cinfigu.php, I have this: define('DB_CHARSET', 'utf8');

    ...Oh, this testing I did with the new development version which you can download here, but I doubt if that makes any difference...

    You are right - it did not help.

    Thanks Ravan

  9. Tara
    Member
    Posted 2 years ago #

    @Ravan, does it mean currently there is no solution for your pluging to highlighting the Indic character set?

  10. RavanH
    Member
    Posted 2 years ago #

    I have no idea why it would not highlight indic characters... If you can give me a link to a live example, I might learn more about the cause.

Topic Closed

This topic has been closed to new replies.

About this Topic