WordPress.org

Ready to get started?Download WordPress

Forums

High CPU on Multisite (5 posts)

  1. Mike Turner
    Member
    Posted 5 months ago #

    My host has informed me that my multisite is consuming extremely high CPU.

    The site itself only receives 1000-2000 page views per day so is really minimal. There are 18 individual network sites created.

    It is a 3.4GHz x 8 core CPU on a VPS but running TOP is coming out consistently with PHP processes at around 50-60%, even up to 80%.

    What's more is that I'm already using MaxCDN as well as having WP Total Cache fully configured.

    I've been through and removed all plugins as well as optimized the database but no change.

    My host has upgraded me to the latest version of php5.4 as well as also trying it on FastCGI but also no improvement.

    I don't know what more I can do. Any ideas please?

    Thanks

    Mike

  2. 18 sites on a network is the exact same as 18 separate WP installs, when it comes to CPU.

    WP Total Cache ... You mean W3 total cache? You may not have set it up properly for your server. It works best if you have some PHP accellerators on, as well as memcacheD or something along those ends.

    Is the 2000 page views total for all 18 sites? Have you checked your logs to see if you're getting hammered by a bot or a log in brute force? Got a firewall up?

  3. Mike Turner
    Member
    Posted 5 months ago #

    Hi Mika,

    Sorry, yes I meant W3 Total Cache. I'm pretty sure it's all set up correctly...

    PHP accelerator is on as well as mpm prefork.

    We've just switched it to dso and still same thing there.

    2000 pages is across all sites (aggregated)

    We have spotted MSN Bots hammering the site tonight so now working on changing the crawl rate with Bing.

    It seems to be on every page refresh that the CPU% shoots up between about 30%-60% at the moment.

    My host has also removed PDO tonight as he thought that may be conflicting as it seems that there are several processes just being kept open and these are the ones that remain high. Also with php <defunct> processes (which is why we tried switching to dso.

    17418 (Trace) (Kill) townvoic 0 54.5 2.3 /usr/bin/php /home/townvoic/public_html/index.php

    It seems to be the index.php which is causing the problems, but just can't figure out anything else to improve it :(

    My host doesn't think that putting up a Firewall would be a good idea...

  4. Mike Turner
    Member
    Posted 5 months ago #

    We're now pretty sure the issue is down to bots. Just counted 35 msn bots hitting us!

    Dispite having bing crawl rate set pretty low and just setting the robots.txt to:

    User-agent: msnbot
    Crawl-delay: 120

    They keep on coming. Fingers crossed it is just this causing the problem, as last resort will be to just block them all via .htaccess!

  5. Your host doesn't think a firewall is a good idea?

    I work for a webhost, and I think they're shortsighted.

    I mean things like this: http://configserver.com/cp/csf.html

Reply

You must log in to post.

About this Topic