WordPress.org

Ready to get started?Download WordPress

Forums

Hiding "posted on.. by..." in posts (Twenty-ten) (11 posts)

  1. marthawilkie
    Member
    Posted 4 years ago #

    I've searched and searched and am still confused about hiding/supressing the "Posted on ...by..." at the top of a post.

    I'm using Twenty Ten for http://conservebuiltworld.com/ (I might also try other themes, so please let me know if directions are theme specific.)

    Some references say it's in the css and others in the php. I have a little familiarity with both, so if someone tells me exactly which file and what to do, I can figure it out (and I know to make back-ups).

    I also see references to paid css upgrade, but if I have a hosted wordpress.org site with my own domain, is this the same thing?

    Do I access css or php via the templates within the WP controls or directly in the file?

    Any help greatly appreciated!

  2. Darrell Schauss
    Member
    Posted 4 years ago #

    You could hide it with css. Or it should be in the index.php,page.php, and/or single.php of theme. I put my css modifications at the bottom of the style.css to override the themes defaults. So I don't create a mess.
    .entry-meta{display:none;}

    You can edit themes within admin then download it as backup or edit on your computer through FTP. Whatever you prefer for workflow.

  3. marthawilkie
    Member
    Posted 4 years ago #

    darrellonsite -- thanks so much, worked like a charm! The other explanations I read were so convoluted, this was a cinch. Yay!

    One more question since you're an expert: how to supress the "Posted in Uncategorized | Comments Off |" at the bottom of the page? I assume this is in the style sheet, but not clear what to do, can I just delete it? Which is it exactly, I see a lot of code about comments.

    Or I've read about hiding (by changing color to white), what's the other way?

  4. Darrell Schauss
    Member
    Posted 4 years ago #

    Quick way with css is .entry-utility{display:none;}. If you have comments disabled (Settings > Discussion) the form should not display either.

    Or inside the index.php and single.php remove everything inside and including the <div class="entry-utility">...</div> and remove comments_template(); to completely remove the form.

    I haven't actually looked at this theme's files but it should be similar.

  5. Mark / t31os
    Moderator
    Posted 4 years ago #

  6. marthawilkie
    Member
    Posted 4 years ago #

    Thanks all!

    I also figured out I can make everything "pages" and have no posts, thereby omitting the post footer.

  7. maxibaut
    Member
    Posted 4 years ago #

    Good topic question. Great answer to the problem.
    This CSS update worked fine for me.

    Thank you very much.

  8. mdg33
    Member
    Posted 3 years ago #

    I think the problem many of us are having is that there is no reference to date or time in any of the php template files anymore.

    Just where exactly is the date information hidden?

  9. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    line 493 to 514 in functions.php of the theme;

    function twentyten_posted_on() {

    it is called in loop.php before the content:

    <div class="entry-meta">
    				<?php twentyten_posted_on(); ?>
    			</div><!-- .entry-meta -->
  10. SEA7
    Member
    Posted 3 years ago #

    Simple and it works! What could be better?

    I decided to comment it and intial it.

    /* Hide post meta (SEA)
    ----------------------------------*/
    .entry-meta{display:none;}

    Put it right below

    .comment-meta,
    .comment-body tr th,
    .comment-body thead th,
    .entry-content label,
    .entry-content tr th,
    .entry-content thead th,
    .entry-meta,
    .entry-title,
    .entry-utility,

    This will help me keep track of what I added and what it does. I am not a programmer, so I get lost a lot.

  11. chamita18
    Member
    Posted 3 years ago #

    Thanks a lot for the solution, this is the part that worked for me:

    Quick way with css is .entry-utility{display:none;}. If you have comments disabled (Settings > Discussion) the form should not display either.

    Thank you, huge help!

Topic Closed

This topic has been closed to new replies.

About this Topic