WordPress.org

Ready to get started?Download WordPress

Forums

Hiding Page Titles in Adventure Journal Theme (15 posts)

  1. WP.User_911
    Member
    Posted 1 year ago #

    I'm very new to code and have no formal training in the matter. In fact this site I'm working on is almost the first crash course I've had with all of this code. I could not locate the place where I could insert that bit of ccs code. I am also running Internet Explorer so that bit about firefox or chrome was irrelevant to me at this point.

    Now I'm running a pre - made theme for my wordpress site so some of the normal files you would find for the default WordPress theme are not available to me. I've been doing a lot of research on this matter and I am still coming up short. Not from lack of understanding but lack of actual knowledge.

    That being said I've come a long way and I understand the code I need to change is located in files associated with the theme I am using. In this case the Theme is Adventure Journal.

    I have access to the following files that make up this particular theme:

    404.php, contexture.php, options.php, archive.php, author.php,

    category.php, comments-popup.php, comments.php, footer.php,

    functions.php, header.php, index.php, loop.php, page.php,

    search.php, single.php (Single Post), tag.php,

    and then . . .

    (One column, no sidebars Page Template) template-onecol.php

    (Three columns, content center Page Template) template-threecol.php

    (Two columns, content left Page Template) template-twocol_left.php

    (Two columns, content right Page Template) template-twocol_right.php

    Style.css (Stylesheet)

    style-ie.css

    The above are all the files associated with my theme.

    As a side note I have a sidebar set up with my page content to the left. <- - - - Reason for editing post.

    So the question continues as follows:
    Where do I find the neccessary code to change so that my page titles no longer appear. Furthermore what do I change the code to so the titles (again) no longer appear.

    I'm sorry for this rediculously long post however the plugin that was originally working to do this for me the "easy" way is now making the title Home not show up on the navigation bar so the plugin is no longer an option. Plus I'd like to do this the "hard" way or the "right" way if possible.

    Thank you in advance for taking the time to read this post. Any help would be great.

    *This Thread was started in response to a Moderator explaining that I had Hijacked another users thread. This has been copied from another thread on another subject. My Apologies.*

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I'm running a pre - made theme for my wordpress site so some of the normal files you would find for the default WordPress theme are not available to me.

    I'm not sure what you mean by the above?? But it may not matter. The easiest way to do what you want is generally to hide the page titles using CSS. Can you post a link to your site - that way someone can look at the specific CSS.

    [P.S. don't worry about the other thread -- happens all the time -- and in your case, wasn't intentional :). ]

  3. WP.User_911
    Member
    Posted 1 year ago #

    Thank you unfortunately I can not post a link to the website as it is not live at this time. I'm running WordPress Locally using WAMP.
    May help to note that the above listed files are available through the Editor in Appearance on WordPress. However I do I have access to the main WordPress files locally on my own computer.

    Furthermore I've been getting roughly the same response as far as adding CSS code. I'm confused however in that I don't understand if I can add CSS Code to .php files or if it is strictly designed for .css files.

    If the latter is the case I only have one .css file for my theme and that is the style.css which has no mention of titles in any way at this time.

    Now I have found references to the title in page.php which I removed. There are more references to the page title in the different template files. Any ways I'm bound and determined to get to the bottom of this please bear with me and I'll patiently work for the answer.

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    CSS code only goes in the style.css file. And yes, you only need one CSS file for the theme. (There might be other ones, for plugins or other special purposes, but a theme typically only has one main style.css file - it applies to all templates and the entire site.) You need to understand a bit about how CSS works -- a great tool is Firebug -- highly recommended for working with CSS.

    http://getfirebug.com

    But here's an important thing -- you really should not be making any changes to any theme files -- because your changes will be lost when the theme is updated. Instead you should create a child theme:

    http://codex.wordpress.org/Child_Themes

    I'll install the theme and see what CSS would be needed to hide the Page Titles.

  5. WP.User_911
    Member
    Posted 1 year ago #

    I used the web developer function in Internet Explorer and inspected the Title of one of my pages it highlighted the following code:

    <h1 class="{display:none;}">

    Maybe the code is wrong because the title is definately still there. Any suggestions?

    P.S. Just so you know I learned something . . . This particular string of code was located in the
    Two columns, content left Page Template (template-twocol_left.php) file.

    Which can be found using the Editor under Appearance in WordPress. The Title rules are decided in this paticular file because I have chosen to use this particular template. Even though there are other templates with the same overall options this is the one I need to edit because it is the template for my particular them that I am using. Please correct me if I'm wrong. Thanks

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    One other thing - can you describe which line you want to remove?

    And BTW, IE really is not a good browser for web development work - are you able to use Firefox or Chrome?

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    That's invalid code - that's why it's not working. You need to change the class back to what it was and then add the display none to that class in the external stylesheet.

  8. WP.User_911
    Member
    Posted 1 year ago #

    Hmmmmm Ok Where do I locate the external stylesheet. . . is that style.css?

    P.S. the original ID was "storytitle" should I be looking for that word in the stylesheet? <----- Reason for Edit

  9. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Perfect, yes, put that class back. And yes, style.css - but please read this again:

    you really should not be making any changes to any theme files -- because your changes will be lost when the theme is updated. Instead you should create a child theme:

    http://codex.wordpress.org/Child_Themes

    The CSS you need to ADD would be:

    h1.storytitle {
       display: none;
    }
  10. WP.User_911
    Member
    Posted 1 year ago #

    Alright one final bit about this then. Will the change to the title that I'm looking for work if I create the neccessary directory within my themes directory as described in http://codex.wordpress.org/Child_Themes, then copy the original style.css file to the new directory and make the change to the code as you described above?

    Please let this be true because I can manage it no problem.

    Oh and Furthermore where do I add that paticular line of code in the style.css file?? <--- reason for edit

  11. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Ideally, the child theme style.css will only contain the changes you've made to the CSS - not a copy of the entire parent style.css file. If you copy the entire thing, it's much, much harder to keep track of your changes, easier to make errors that are harder to find, and it also creates unnecessary duplicate code (slows down your site).

    That said, if you are adding changes to a copy of the entire file, put the changes at the bottom of it.

  12. WP.User_911
    Member
    Posted 1 year ago #

    Alright I have found the solution with your help and I thank you so much. I added the above code to the end of my style.css File. No bannans did not work. *Scratches Head in Frustation*

    Then I removed the added code and put it at the end of the
    /* =Master Page Classes located in the style.css file and Viola Success my titles are no longer showing on my pages and you have just helped me edit my first .css file THANKS!! So Excited.

    I did however do this edit in the orginal template but I do understand what you are saying about a Child-Theme. I don't have time to master that just yet but I do understand the basics.

    I was thinking to save time my theme is provided under the GPU Licsence so I think I will just copy the files into a brand new folder of my own label and maybe do some editing to the name of the theme in the style.css file.

    My very last question if your up to helping me one final time. Will doing the above as far as copying all the files and folders of my theme into a new folder in /wp-content/themes keep original theme creators from updating my files?

    Thanks again it's working great that was so simple yet so tricky lol.

  13. Ian
    Member
    Posted 1 year ago #

    I have exactly the same problem, in fact it is a problem I've had for literally years. I keep coming back to it and after a while I keep giving up in sheer frustration. I am using the latest version, WordPress 3.5.1

    I don't want hijack this thread, so I don't know if I should create yet another request for help with this problem.

    I have read through a lot of the above posts and replies. In style.css above the H1 tag, and also I tried at the end of the file, I pasted in:

    h1.storytitle {
    display: none;
    }

    Still it doesn't work. I have read through many other posts here in the forum and searched for code in various pages, removed some and retried, still no change. At least the site still works. The site is live <u>here</u>

    If I ever get this page title removed, I may then spend a few years working out how to remove comments from static pages, but let's leave that one for now. If someone like me with knowledge of HTML and basic understanding CSS has difficulty, what hope is there for most people?!

    Why don't WordPress officially just make hiding the page titles and comments on static pages an option? There seems to be so much call for it.

  14. Andrew
    Forum Moderator
    Posted 1 year ago #

    Why don't WordPress officially just make hiding the page titles and comments on static pages an option? There seems to be so much call for it.

    The default WordPress themes were only made to satisfice.

    If someone like me with knowledge of HTML and basic understanding CSS has difficulty, what hope is there for most people?!

    That's a compromise you or others in similar positions will have to accept, or hire someone at http://jobs.wordpress.net . You can't work in the role of a developer with no knowledge of the technologies involved.

    I don't want hijack this thread, so I don't know if I should create yet another request for help with this problem.

    Then, please, create a new thread.

  15. greenbeltlandtrust
    Member
    Posted 1 year ago #

    I read through this thread carefully, as I have the exact same problem, and the same Adventure Journal theme. I did what WP User_911 suggested worked for him (Then I removed the added code and put it at the end of the /* =Master Page Classes located in the style.css file), but it didn't work. I now have an annoying bit of text below the Page Title that says 'display: none; }>' on the website (even though I removed the css code that was added (h1.storytitle {
    display: none;
    })

    Help?! I don't want to keep playing around with anything until I get a little feedback from folks who know more than I do!

    website in draft form right now: newsite.bountyofbentoncounty.com

Topic Closed

This topic has been closed to new replies.

About this Topic