WordPress.org

Ready to get started?Download WordPress

Forums

Email Before Download
[resolved] Hide/Mask Real Link leads to Blank page (works fine without this option) (12 posts)

  1. TSains
    Member
    Posted 1 year ago #

    Hi,
    I have read the various topics on support regarding my issue but I am unable to resolve the problem.

    Could you please help me.
    I am able to download the file from the download link when Hide/Mask Real Link option is disabled but when this option is enabled then I am NOT able to view the linked file (blank page opens).
    Note: cURL is enabled.

    http://wordpress.org/extend/plugins/email-before-download/

  2. mandsconsulting
    Member
    Plugin Author

    Posted 1 year ago #

    Hi TSains,

    Thank you for your interest in our plugin.
    Sometimes it's hard to determine what goes wrong. Firstly we want to make sure that you went through our suggested steps for users in this sticky post
    http://wordpress.org/support/topic/plugin-email-before-download-sticky-getting-faster-support?replies=17
    If you follow those steps and you are still having difficulties, we might need more details from you.
    It would be helpful if you could provide then the url to your test page. Also, what type of files you want to provide on that page?

  3. TSains
    Member
    Posted 1 year ago #

    Hi,

    Thank you very much for your reply.

    The url is http://www.mwlimited.com/investment-opportunities/
    and I want to provide .pdf files.
    If you could email me on 415764 (at) gmail.com to enable me mail you the Admin login details.

    Thanks
    Tina

  4. mandsconsulting
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Tina,

    Thanks for your reply and test url.
    After some testing we're under the impression that our plugin doesn't have permission to read the file.
    Can you verify this with your environment configuration and ensure the owner of the process running our plugin has read permissions to that file?

  5. TSains
    Member
    Posted 1 year ago #

    Hi,

    Thank you very much for having a look at my problem.
    I am newbie to wordpress. Could you please guide me how to check the environment configurations? or if you could kindly email me on 415764 (at) gmail.com and I could give you the Admin login details?

    Thanks again
    Tina

  6. TSains
    Member
    Posted 1 year ago #

    Hi,

    I have been able to check the permissions of wp-content/uploads folder and the permissions are set to 755. However the permissions of the linked file were set to 644 but changing that to 755 also did not resolve the issue.

    Thanks
    Tina

  7. mandsconsulting
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Tina,

    Unfortunately we can't see what exactly happen in your case and are not able to check if our code is able to read the file on your server.
    So now we only can suggest to change for a while the settings of your php, in php.ini file.
    You need to change the following options there to
    error_reporting = E_ALL & ~E_NOTICE
    display_errors = On

    This might help us in some way to debug the issue.

  8. TSains
    Member
    Posted 1 year ago #

    Hi,

    I have made the above suggested changes.
    Please check.

    Thanks
    Tina

  9. TSains
    Member
    Posted 1 year ago #

    Hi,

    I have made the above suggested changes.
    and updated the plugins Email before download and Form 7

    now the error is : Failed to load PDF document.

    Thanks
    Tina

  10. TSains
    Member
    Posted 1 year ago #

    Hi,

    Could you please update me on the progress?
    or next step? as this is the only feature not working on my website.
    and I am eager to get it working.

    Thanks
    Tina

  11. mandsconsulting
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Tina,
    We were right assuming that the file is still cannot be read by our code.
    The debugging shows that the reason of issue is php setting on your server.
    Can you try change the option in your php.ini to
    allow_url_fopen 1

  12. TSains
    Member
    Posted 1 year ago #

    Hi,

    It works.
    Thank you. Thank you. Thank you.
    I can't express my happiness in words.
    God bless and thank you for your time spent on solving the problem.

    Tina

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags