WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
Hide Login Area interferes with Password Protected pages (12 posts)

  1. cwendt01
    Member
    Posted 3 months ago #

    I have a page on my site that requires somebody to enter a password in order to see the data. My site is using WP's default "Password Protect" feature, so no other plugins help with this.

    Since the site was built a year ago, we've been using the Hide Login area feature. However, now it's not letting the Password Protected page to work. When we enter the password, it redirects us to http://www.mydomain.com/wp-login.php?action=postpass -- which shows up as a "nothing found" page.

    I've been forced to disable the Hide Login Area feature, but that's not good since a lot of people use this site and now we have to notify them the login URL has changed. How can I get around this, please?

    https://wordpress.org/plugins/better-wp-security/

  2. ricomtl
    Member
    Posted 2 months ago #

    Having the same exact issue here. Pass protected posts/pages are no longer accessible once you enter the password when the "Hide Login" feature is enabled.

    anyone??

  3. anne111
    Member
    Posted 2 months ago #

    Yes, same problem here. I had to disable the Hide Login feature to get password protected pages to work properly again. I'm using latest versions of WP and the iThemes Security plugin. Hope the iThemes folks will respond to this thread.

  4. iThemes Support
    Member
    Plugin Author

    Posted 2 months ago #

    Can one of you guys contact us directly. This was confirmed fixed in both our testing by other customers who reported it. Would love to see what is different with you guys. http://ithemes.com/security/bugs/

    CW

  5. ricomtl
    Member
    Posted 2 months ago #

    Will write you in a few minutes. Thanks.

  6. anne111
    Member
    Posted 2 months ago #

    thanks! I'm away from my desk, but I'll respond later as well. I appreciate your responding to this!

  7. cwendt01
    Member
    Posted 2 months ago #

    It's working now for me! I'm running WP 3.9 and iThemes Security 4.2.2.

    For me I had to deactivate Redirection (a plugin that's used for remembering 404s and such), clear the site's cache, test the password-protected page, and re-enable Redirection. Without doing that it'd keep redirecting me to an error page when trying to access the password-protected page.

    Thanks so much for fixing this bug, iThemes! :)

  8. iThemes Support
    Member
    Plugin Author

    Posted 2 months ago #

    Hey Cwendt101,

    That's great to hear! If anyone else could confirm this as well it'd be greatly appreciated.

    Please let us know!

    Thanks,

    Gerroald

  9. ricomtl
    Member
    Posted 2 months ago #

    WP 3.9 + 4.2.2 and the 404 page is still occuring on password protected pages. Site's cache was cleared. I have also sent you a private msg. Thanks.

  10. anne111
    Member
    Posted 2 months ago #

    I'm afraid I'm not going to be able to test this again for a while on our live site, since we expect a lot of activity soon on that password-protected page and I can't risk having people reach the 404 page. So I have to leave the Hide Login Area feature off for now. But I look forward to hearing more about what might fix the problem so that I can turn the feature on again eventually. We're not using a Redirection plugin, so that wasn't the problem with our site. I am using the WordPress default feature for password protection, and except on browsers that had been logged in as admin on the site, the password-protected page also kept redirecting to the error page.

  11. dsputa
    Member
    Posted 1 month ago #

    I still have problem with this for months. We don't use it too much, but I was trying to fix it few times without success. With the sec.plugin disabled, it works fine, with the plugin enabled, it would just go to 404. I use the hide backstage feature. I submitted the bug report.

  12. JamesMcWhorter
    Member
    Posted 3 weeks ago #

    Having a similar problem.

    When I have the Hide Login feature activated the Reset Password link, on the login page, takes me to a 404 page. When the Hide Login feature is deactivated the Reset Passoword link works again. Note the action in the URL.

    /wp-login.php?action=lostpassword

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.