WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
Hide Backend not working (10 posts)

  1. Andrew Areoff
    Member
    Posted 9 months ago #

    I've enabled the HideBackend function with a six digit alpha-numerical code.

    I've added the code that the plugin produces to the .htaccess file and verified it's there on the server.

    But the new login URL just produces a page not found error when I try to access via this code.

    Any ideas?

    http://wordpress.org/extend/plugins/better-wp-security/

  2. Handoko
    Member
    Posted 9 months ago #

    Are you sure you have typed the correct login URL?

    Can you please tell me your website address? I may able to find your 'correct' login URL.

  3. Andrew Areoff
    Member
    Posted 9 months ago #

    Thanks Handoko. I have definitely got the correct URL - I can't give you it here as it's a live website for a client but it goes something like this:

    http://www.domain.com/site/xxxxxx

    /site/ is the folder the site is located in on the server

    xxxxxx is the six digit code I added

    I take it there's not .php or anything to add at the end?

  4. Handoko
    Member
    Posted 9 months ago #

    Okay, it seems you installed the site in a WordPress Multisite environment, isn't it?

    I can perform some tests to find your login URL. I need the domain name to perform the tests. I won't know the login URL if I don't make any tests (hacking attempts).

    It's okay if you have your reasons not to make it public. I guess your issue happens because you're using a multisite environment. After you enabled the hide backend, you normally can only login using:
    http://www.domain.com/xxxxxx

    Note:
    - xxxxxx is your login slug (six digit code)
    - don't use /site
    - don't use .php

  5. Andrew Areoff
    Member
    Posted 9 months ago #

    No, it's not a multisite environment, single WP site on the domain with the installation in a folder called /site/

  6. Handoko
    Member
    Posted 9 months ago #

    That's the problem.

    If I'm not wrong, the plugin won't work correctly if your website isn't installed on a main or sub domain. Did you set the /site/ as a sub domain? Or perhaps (later) you may need to make it a multisite.

    For now, I only can recommend you to remove the plugin. You can not simply delete it because it won't work. Here has all the information you may need, especially the item no. 1:
    http://wordpress.org/support/topic/after-log-in-screen-goes-blank

  7. Andrew Areoff
    Member
    Posted 9 months ago #

    Ah, then that plugin won't work for me at all as I have to have WP in a folder since I have other folders on the site for non-wordpress development etc.

    I'm using WP Stealth Login for obscuring the login URL which seems to working quite well.

  8. Andrew Areoff
    Member
    Posted 9 months ago #

    p.s. I have the better WP security plugin working for other things though which seem to be quite good, just not working on the login URL hide function.

    So I assume I can still leave it enabled and use another plugin for hiding the login URL, although I realise that it means more plugins and more issues potentialy.

  9. Handoko
    Member
    Posted 9 months ago #

    Sure, you should keep the plugin. It is really a great security plugin.

    For login securiy I recommend you Login Security Solution plugin. I don't use it, but it seems to be a good one and I like the author actively provides helps in the support forum.

  10. Andrew Areoff
    Member
    Posted 9 months ago #

    Ok, thanks for that - I will check out the Login Security Solution.

    Thank you for your help this week!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.