WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7 Modules
[resolved] Hidden Fields Not Displaying Contant in Emails (7 posts)

  1. jon_steele
    Member
    Posted 1 year ago #

    Apologies if this is a slight repeat of other hidden field data not appearing in emails, I have checked those posts and still have the problem. Is there anything else to check?
    I have tried post_title, post_url and a custom_field but can not get any to populate an email.
    Also one of my contact forms is loaded via the contact form 7 widget - does this affect this plugin at all or what data you may get from the web site?

    Below is my form;

    <p>Your Name (required)
    [text* your-name 30/] </p>

    <p>Your Email (required)
    [email* your-email 30/ ] </p>

    <p>Your Telephone(required)
    [text* Telephone 30/] </p>

    <p>Your Message
    [textarea your-message 25/] </p>
    [hidden post_title]
    [hidden post_url]
    [hidden custom_field-et_address]
    <p>[submit "Send"]</p>

    And the email;

    From: [your-name] <[your-email]>
    telephone: [your-telephone]
    Message Body:
    [your-message]
    [post_title]
    [post_url]
    [custom_field-et_address]

    Any help would be much appreciated?
    Thank you
    Jon Steele

    http://wordpress.org/extend/plugins/contact-form-7-modules/

  2. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Jon,
    You're right: this wasn't working! I've updated the plugin to fix this issue: Version 1.2.3, out now.

    Thanks!

  3. jon_steele
    Member
    Posted 1 year ago #

    Does what it says on the tin, ta muchly Zack! I'm impressed.
    Best regards
    Jon Steele

  4. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, Jon.

    I'd appreciate it if you could rate and review the plugin!

  5. Designophobia
    Member
    Posted 1 year ago #

    I'm having the same problem. I'm using WordPress multisite v3.4.2 and Contact Form 7 v3.3.1 and Contact Form 7 Modules: Hidden Fields v1.2.3. My emails come in like:

    From: Name
    Email: email@address.com
    Subject: post_title
    Custom Field 1: custom_field-custom_field_1
    Message: test

    Any thoughts?

  6. gattattack
    Member
    Posted 1 year ago #

    I can confirm this issue too. CF7 3.3.1 and modules 1.2.3

    The default values are not working - <input class="wpcf7-hidden" type="hidden" value="post_title" name="hidden-524">

  7. asisrodriguez
    Member
    Posted 1 year ago #

    the same for me, not working and i can not find the previous version to return. please, help
    Asis

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic