WordPress.org

Ready to get started?Download WordPress

Forums

Hi-load mysql server issue (13 posts)

  1. miob
    Member
    Posted 9 years ago #

    Hello !

    I'm using wordpress, and having big troubles with my stability of server, i'm getting thousands hits to mysql, and this couldn't handle my server, so i decided to grab all online content from index page and copy it somewhere else, now my users don't access mysql with each loads of page.
    so mysql requests dropped to about 5% from 100%

    but sometimes those small requests can kill mysql and cancel connection, i have enabled loggin for longer mysql requests, and i can see there a lot of such requests:

    SELECT option_name, option_value FROM wp_options WHERE autoload = 'yes';
    # Time: 050526 12:03:39
    # User@Host: root[root] @ localhost []
    # Query_time: 0 Lock_time: 0 Rows_sent: 255 Rows_examined: 255

    Can you please tell me what i didn't disable yet, and what that request is trying to do ? where i could disable this, and what php file is doing that.

    thanx

  2. moshu
    Member
    Posted 9 years ago #

    Are you using many plugins? Some of them are really heavy on DB. Try to deactivate them one by one to see which one might cause problems.

  3. miob
    Member
    Posted 9 years ago #

    plugins ? i didn't install anything, only new template, but this has nothing to do with mysql accesses, cuz it's all loading without mysql, i have online only search box, removed calendar too.

    and i forgot comments, hasn't that something with comments ?
    cuz i have moderated comments, i got a lot of spam

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Where is your server ?
    Who is hosting you ?

  5. miob
    Member
    Posted 9 years ago #

    i just checked plugins section, there's nothing installed

  6. miob
    Member
    Posted 9 years ago #

  7. miob
    Member
    Posted 9 years ago #

    but i think this matter has nothing to do with hosting company, my opinion is that could happen on any server, even hosting guys said try to avoid mysql complettly if you're running hi traffic sites

    i think i just need to figure this row:

    SELECT option_name, option_value FROM wp_options WHERE

    what exactly does this request ? which php file ?

  8. miob
    Member
    Posted 9 years ago #

    Here you can see load on the server:
    http://vodex3.exmasters.com/hotsanic/system/load.html

  9. davidchait
    Member
    Posted 9 years ago #

    jeez, just search for any part of the string in the php files. it's retrieving the core options/settings for WP, done at pageload.

    You could have a dozen (or dozens) sql queries per page and not hurt performance in the slightest. Something else is going on if you're having real performance issues.

    If you want to staticize stuff, look at WP-Cache as the best method to do so.

    -d

  10. miob
    Member
    Posted 9 years ago #

    i've found this string in functions.php inside of function get_alloptions()
    and this function uses update_option() and get_settings() nothing else

    hm i see something trackback() and weblog_ping() uses get_settings()
    i saw in my posting form {Send trackbacks to:}and sometimes i have there filled some weird data
    What is this ? probably this is killing my mysql

    And what you meant WP-Cache, what kind of method ?

  11. davidchait
    Member
    Posted 9 years ago #

    Sounds like you need to fix your machine/mysql-config... if you're having that much trouble, hacking around without solving the root problem isn't going to get you far, and might just make more problems in the long term. ;)

    Search for WP-Cache.

    -d

  12. miob
    Member
    Posted 9 years ago #

    i'm having hi-load issues only sometimes, in the most traffic caps, now it's quite fine, but i'd avoid uf such mysql requests if i can...

    where i have to find for string "wp-cache" ?, i was looking in wordpress files, and nothing has been found.

  13. miob
    Member
    Posted 9 years ago #

    ok, gus it seems like i finally resolved my issue,
    i've installed even a plugin:
    http://mnm.uib.es/gallir/wp-cache-2/

    i'm sure this will help someone too

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags