WordPress.org

Ready to get started?Download WordPress

Forums

HELP!Redirection being done that i didn't set (29 posts)

  1. Gelizzy88
    Member
    Posted 5 years ago #

    I need someone to help me so bad. When i go to my blog's homepage, it redirects it to one of my blog post instead of going to the homepage. I didn't set this up like this and this just recently started happening after i published my latest blog post. I deleted the blog post and that still didn't help anything

    My homepage should be:http://www.vivalavoiz.com but instead it goes straight to http://www.vivalavoiz.com/2009/01/congress%E2%80%A6please-bailout-the-porn-industry/

    Somebody please help because i can't even get back to my homepage and i have no clue how it got like this. I already checked the settings to and that is set to my homepage but it still redirects

  2. Gelizzy88
    Member
    Posted 5 years ago #

    is anyone else having this problem?

  3. Check your .htaccess files

  4. RipRapRob
    Member
    Posted 5 years ago #

    In Admin, try checking your settings under SETTINGS >> READING:

    First setting: "Front page displays": Is the setting here "Your latest posts" or have you selected "A static page (select below)" by mistake?

    /Rob

  5. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    what ipstenu said. if htaccess check/fix not the problem, you might want to check index.php or home.php in the theme folder on your server, someone might have hacked your files to redirect to a page you didn't create re save porn something. Delete the index.php or home.php and reupload the "clean" file from your computer. Then go about hardening your WordPress - special mention to your database.

  6. Gelizzy88
    Member
    Posted 5 years ago #

    so what do i do to my htaccess files?

  7. RipRapRob
    Member
    Posted 5 years ago #

    Have you at one time made the page http://www.vivalavoiz.com/2009/01/congress%E2%80%A6please-bailout-the-porn-industry/ ?

    If so, have you checked the setting I suggested?

  8. Gelizzy88
    Member
    Posted 5 years ago #

    ok so i deleted and and uploaded it again and it still isn't working. Now my site isn't coming up at all

  9. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    ok so i deleted and and uploaded it again

    what exactly did you delete and upload? please be specific

  10. Gelizzy88
    Member
    Posted 5 years ago #

    yes it did exists but i deleted it to see if it would fix the problem. it didn't

  11. What's in your .htaccess? It should have this for WordPress:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  12. Gelizzy88
    Member
    Posted 5 years ago #

    i deleted the index.php and re uploaded it and now my blog isn't showing up at all.

  13. Gelizzy88
    Member
    Posted 5 years ago #

    where is my .htaccess files supposed to be located? I don't even see it. The only one i see that says.htaccess is included in a redirect plugin folder

  14. It should be in the root of your public_html folder.

    Is WordPress installed to a SubFolder or the main public_html folder?

  15. WebDev WaxLotus LLC
    Member
    Posted 5 years ago #

    The dot/fullstop/period in front of .htaccess tells *nix that this is a file that is normally hidden from the user, so you may not see it unless your file browser is set to show you the dot/hidden files.

    Paste Ipstenu's code into a file you create using notepad (not Word etc) and ftp it to the root of your public_html folder (or where the index.php file was if using a subfolder like blog etc). You can get another copy of the index.php file from the wp2.7 source zip...

  16. Gelizzy88
    Member
    Posted 5 years ago #

    its installed in the public_html folder

  17. Okay, then your index.php in your root should be:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

    And you should see a .htaccess file in that folder (you may have to turn on viewing of hidden files)

  18. Gelizzy88
    Member
    Posted 5 years ago #

    ok i found it.lol it was in hiding here is what its says

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  19. Gelizzy88
    Member
    Posted 5 years ago #

    this is what my index.php in the public_html says

    <?php
    /**
    * Front to the WordPress application. This file doesn't do anything, but loads
    * wp-blog-header.php which does and tells WordPress to load the theme.
    *
    * @package WordPress
    */

    /**
    * Tells WordPress to load the WordPress theme and output it.
    *
    * @var bool
    */
    define('WP_USE_THEMES', true);

    /** Loads the WordPress Environment and Template */
    require('./wp-blog-header.php');
    ?>

  20. Gelizzy88
    Member
    Posted 5 years ago #

    ooo :( nothings working

  21. Your .htaccess is fine.

    Go into your wp-admin side, see if there are any users you don't recognize.

  22. Gelizzy88
    Member
    Posted 5 years ago #

    there is thisone new user because its an open blog. He signed up twice

  23. Gelizzy88
    Member
    Posted 5 years ago #

    could it be one of the users? how do i check it and fix it?

  24. Gelizzy88
    Member
    Posted 5 years ago #

    oh so i have been hacked??

  25. It's a possibility, but the debugging methods of a hack are about the same for this so... Assume the worst and be surprised if it's not.

  26. Gelizzy88
    Member
    Posted 5 years ago #

    ok i see a file in my wp-content that wasn't there before. It wont delete and i have tried to delete it. It won't go away

  27. Gelizzy88
    Member
    Posted 5 years ago #

    its called gt-cache

  28. gt-cache is from the global translator plugin, you can probably leave it alone.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags