WordPress.org

Ready to get started?Download WordPress

Forums

HELP....Permalinks.....Redirecting back to index (13 posts)

  1. kinlongso
    Member
    Posted 6 years ago #

    Hi I'm new to using wordpress, I have been asking for help from other wordpress bloggers at a different forum, but have not had any luck with my problem.

    http://www.wpdesigner.com/forums/showthread.php?p=395#post395

    Here's the problem, i have been using default WP permalinks before, I'm nowing trying to change it to date and name based, when i change it the permalink DOES change, but the content stays as is in the index.
    For example, when I click on post "1", it doesn't go into post "1", it only displays the 5 posts that are meant to be displayed in the index, however the permalink does change to post "1".

    Has anyone had this problem? Yes I did CHMOD my .htaccess file before i changed my permalinks. Is there something that i missed or didn't do while i was changing my permalinks?

    If you didn't quite understand what i mean, here is my blog: http://blog.gadgetlite.com/ thanks very much.

  2. Chris_K
    Member
    Posted 6 years ago #

    I'd say your Permalinks aren't working. Check that page for troubleshooting tips.

    In particular, confirm with your host that mod_rewrite and AllowOverride are both on and enabled.

  3. kinlongso
    Member
    Posted 6 years ago #

    Thanks for your reply... could you tell me how i can find out if my mod_rewrite and allowoverride are enabled? Where is it located? My webhosting? or WP?

  4. Chris_K
    Member
    Posted 6 years ago #

    Those would be questions for your host.

  5. kinlongso
    Member
    Posted 6 years ago #

    is it possible for someone to show me what a proper basic .htaccess file that works with the permalinks /%year%/%monthnum%/%day%/%postname%/ should look like?
    I have gone through the post at wordpress about permalinks, but still can't find the problem.

  6. Chris_K
    Member
    Posted 6 years ago #

    Do you have an .htaccess file already?
    Can WP write to it -- if not, when at Options -> Permalinks you'll see a message at the bottom of the page with instructions.

    here's an example of the WP stuff in one of my .htaccess files:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  7. kinlongso
    Member
    Posted 6 years ago #

    Thanks for your reply, hmm....i have the exact same thing on my .htaccess file. Also, the Options>Permalinks doesn't seem to state any problems in updating, no messages at the bottom either.....

    I've changed my blog back to the normal default permalinks now and everything immediately returns back to normal, no problems with reading the posts at all....

  8. Chris_K
    Member
    Posted 6 years ago #

    Which brings us back to: does your host support mod_rewrite?

    Here's one way to check:
    Create test.php with the following contents:

    <?php phpinfo() ?>

    (no carriage return on the end! just one line).

    Upload it to your site and then point your web browser at it. There's going to be all sorts of info shown, check to see if mod_rewrite shows up anywhere on the page (hint: use your browser's search...).

    When done, delete test.php from your site.

  9. kinlongso
    Member
    Posted 6 years ago #

    Thanks.
    after searching, "mod_rewrite" is no where found on that page.

  10. Chris_K
    Member
    Posted 6 years ago #

    ah ha! Well, you could ask the host and see if they'll install it for you.

    Say, is your host apache or IIS? Is it netfirms? (shame on me, I should've asked those much sooner).

    Anyways, if you look over the Permalinks page, find the section on "almost pretty" permalinks. You could still do those.

  11. kinlongso
    Member
    Posted 6 years ago #

    hi, thanks. I've tried to use the almost pretty permalinks, it does indicate "an almost pretty permalink" when i mouse-over one of my post's links in the index. But when i click into it, it says "Not Found".....screenshot when i click into one of the posts: http://img59.imageshack.us/img59/2473/ssnp2.gif

    Haha, so much for choosing Lycos as my hosting......I'm in the UK....and didn't know much about hosting when i chosed it. Now when I ask them for abit of support, they say that they are not responsible for softwares that are not their products and refers me back to contacting wordpress instead....Argh!!!

  12. kinlongso
    Member
    Posted 6 years ago #

    looks like everything is stuck for me at lycos!!?? I've even tried some of the URL rewriting tricks, URL rewrite plugins on the permalinks page, but still indicates post "Not Found"...arghh...looks like i won't be able to do anything for my permalinks until i switch hosts?

  13. gijsbrouwer
    Member
    Posted 6 years ago #

    @kinlongso: maybe you already found the solution but otherwise, this works for me, and i'm also a lycos user ;-)

    http://martijn.van.steenbergen.nl/journal/2007/07/01/pretty-wordpress-permalinks-without-pathinfo/

    as a tip, there are several server globals that can be used to retrieve the URI. In my case, PATHINFO is not available. You could also use:
    REQUEST_URI, QUERY_STRING and ORIG_PATH_INFO

    @HandySolo: not all providers show the apache2handler settings ! Lycos does support url-rewriting, but it simply doesnot show up at the phpinfo pages

Topic Closed

This topic has been closed to new replies.

About this Topic