WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Help: wp-login.php just shows a blank page (8 posts)

  1. tinwatchman
    Member
    Posted 6 years ago #

    Hi, everyone,

    I'm relatively new to WordPress, but nonetheless have been trying to set up a blog for a friend on his site. Here's my problem: the blog seems to be working fine. But every time I click on the "Login" link, it simply brings me to a blank page.

    The site address: http://www.captainactionnow.com/news/

    Things that I have tried before coming here:
    - Clearing my browser cache
    - Clearing my cookies
    - Tried reuploading the copy of wp-login.php I have stored locally
    - Downloaded a new version of WordPress and uploaded the wp-login.php from THAT up to the server
    - Followed these instructions here - twice; once to check my work from before.
    - checked to see if there was a wp-content/cache folder I could clear (there wasn't);

    I'm kind of tearing out my hair here. Any suggestions?

    Thank you.

  2. whooami
    Member
    Posted 6 years ago #

    look inside your wp-config.php for any line breaks or spaces BEFORE the opening <?php

    If you view the source of your pages in your browser, you have mysterious white space before everything else.

    Also, upgrade. This issue pales in comparison to the problems associated with having an exploited site.

    (wheres my fricken gravatar, Ive added two -- there it is!!)

  3. tinwatchman
    Member
    Posted 6 years ago #

    look inside your wp-config.php for any line breaks or spaces BEFORE the opening <?php

    I've checked that file. I'm afraid I don't see anything.

    Also, upgrade. This issue pales in comparison to the problems associated with having an exploited site.

    *sigh* Guess that's the one thing I haven't tried. Okay. I'll give it a shot. Any other suggestions, in case upgrading doesn't fix the issue?

  4. whooami
    Member
    Posted 6 years ago #

    upgrading prolly wont fix that issue. IF you are absolutely positive that there are no line breaks or spaces in wp-config.php. which I should add, most ppl are sure they dont see any when initially asked to look, and then we end up finding it later, then theres a standard way of troubleshooting..

    1 === you disable plugins (you havent mentioned doing that)

  5. tinwatchman
    Member
    Posted 6 years ago #

    IF you are absolutely positive that there are no line breaks or spaces in wp-config.php

    No line breaks whatsoever? Or just no line breaks or spaces before the "<?php" tag?

    you disable plugins (you havent mentioned doing that)

    Don't have any except for the two basic ones that came with WordPress. Also, to disable those, don't I need to have access to my Admin panel in the Dashboard? -- Which I can't, because it won't let me log in?

  6. whooami
    Member
    Posted 6 years ago #

    No line breaks whatsoever, thats correct.

    The VERY top of the file should be

    <?php

    and thats that.

  7. tinwatchman
    Member
    Posted 6 years ago #

    Spot checked both ws-config.php and ws-login.php in Notepad. Made sure that both files started with <?php. So yeah, that looks solid to me. Guess I'm going to go ahead with the upgrade. Wish me luck...

  8. tinwatchman
    Member
    Posted 6 years ago #

    Okay, that seems to have cleared everything up for now. Thanks for the advice! Appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic