WordPress.org

Ready to get started?Download WordPress

Forums

help with wp grins problem please...weird (14 posts)

  1. oncidium
    Member
    Posted 8 years ago #

    I have WP Grins in my WP 2.0 intallation and it was working fine. Now all of the sudden the smilies don't show in the posts...the pics still show on the admin panel and the commments area and in comments they are still clikable...just the pic doesn't show up in the actual post. And in the admin for some reason the smile pics are there but not clickable now. Any ideas? I checked the flies that you put the php command in and they all look the same as when I put the <?php wp_grins(); ?> in.

    see: http://www.divaknitting.com/blog

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

  3. oncidium
    Member
    Posted 8 years ago #

    podz...thanks for checking in. The smilies are supposed to show up in posts and comments...right now they are just showing as :smile: in text. I checked the vars file too..they're all there. The acutal smile pics are in blog/wp-includes/images/smilies/ and they're all still there. Weird because they were working fine, now wonky. I switched back to my old theme for a minute to check but they problem is there as well.

    Oh and thanks for letting me know about the other issues as well...those are fixed now.

  4. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Can you make one post with lots of smilies in ?
    A separate post and link it directly here ?

  5. oncidium
    Member
    Posted 8 years ago #

    Here is a post that should have a smiley ":badgirl:" in the first line. http://www.divaknitting.com/blog/?p=224

  6. Mark (podz)
    Support Maven
    Posted 8 years ago #

    I'll check.
    Can you sign off the other thread and keep this issue in one place ? Makes life easier :)

  7. Mark (podz)
    Support Maven
    Posted 8 years ago #

    That looks like you have unchecked the Option for WP to convert smilies to images...

  8. oncidium
    Member
    Posted 8 years ago #

    doh! Of course I didn't check the most simple thing...I never unchecked it though so that is bizarre. AND if I click it now and hit update, it doesn't save the new setting! What now?

  9. Mark (podz)
    Support Maven
    Posted 8 years ago #

  10. oncidium
    Member
    Posted 8 years ago #

    Just getting more strange. I had deleted the cache days ago and added this to my wp-config to disable it.

    define ('WPLANG', '');

    /* Stop editing */
    define('DISABLE_CACHE', true);
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    However, when I just checked there was the cache file and the wp-config didn't have the line! I just repeated both things and still no smiles. When I go to options, convert smiles and update, it still won't save.

  11. hiddengloss
    Member
    Posted 8 years ago #

    I have the same problem as oncidium! The smilies don't show in the post but they show up in the admin panel! I then looked if the option for smilies was unchecked. And it was. But if I want to update so that it converts the smilies it won't save. I tried putting this: define('DISABLE_CACHE', true); into wp-config but that didn't work either! Can somebody please help?

  12. girlgeek73
    Member
    Posted 8 years ago #

    Have you checked the names and the locations of the smilies in the wp-grins.php file? Is the path correct? I use the more-smilies plugin along with wp-grins. If a filename is incorrect you will see the :smile: instead of the actual image.

  13. hiddengloss
    Member
    Posted 8 years ago #

    I did that! And they are correct! The problem is that I can't save the options in the admin panel if I change them!

  14. girlgeek73
    Member
    Posted 8 years ago #

    Do you get any error messages when you attempt to save the options? Have you tried deleting the plugin, reinstalling? Also-one thing I noticed after upgrading to WP2.0-if you have the built-in editor enabled, it wouldn't allow me to click a smilie and insert to a post. I would try reinstalling the plugin, enable it, turn off the text editor (Users/Your Profile-uncheck "Use the visual rich editor when writing") and try a test post.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.