WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Help with wordpress website!! (5 posts)

  1. JavaChipMocha
    Member
    Posted 1 year ago #

    Just recently added my wordpress website from a local wamp server to a live server yesterday and followed all the steps ftp, phpmyadmin, wp-config.php etc. The site is up and running, but when you click any of the links or the pictures if states: Error establishing a database connection. Then I can see that in the url box it is still trying to point to http://localhost/FHC/?page_id=212. I have uploaded all the content I need and can still see it when logged into my wp-admin account, but it is not showing up on the server. Can anyone give me a step by step process? I am just scared I am going to type or do something wrong! Thank you

    Here is the website adddress: http://www.fremonthc.com

  2. Beatboxx
    Member
    Posted 1 year ago #

    The problem is partially that you need to change the Site Url of your website. You can do this in the dashboard --> Settings --> General. This is still localhost in your case, you should change it to http://www.fremonthc.com

  3. gerald@WPcustoms
    Member
    Posted 1 year ago #

    my prefered way to move local installations to online server is a fresh installation.
    setup wordpress on the webhost and export your localhost data. Then import it online through TOOLS -> Import with WordPress Importer Plugin.

    this way you`ll be save with a running default WP installation.

    the quick and dirty method is in your wp-config.php file.
    change the database and sql logins there (must match your online webhost's database)

  4. JavaChipMocha
    Member
    Posted 1 year ago #

    Beatboxx: WordPress Address (URL) http://fremonthc.com
    Site Address (URL) http://fremonthc.com
    Enter the address here if you want your site homepage to be different from the directory you installed WordPress.

    I already changed the General settings to this.

    Gerald: I have already updated the wp-config.php file to the webhost's database below.

    /** The name of the database for WordPress */
    define('DB_NAME', 'fremonthealth');

    /** MySQL database username */
    define('DB_USER', '******');

    /** MySQL database password */
    define('DB_PASSWORD', '********');

    /** MySQL hostname */
    define('DB_HOST', 'mysql.fremonthc.com');

    username and password are starred just for protection. Thanks for your responses I hope to get this figured out asap!

  5. JavaChipMocha
    Member
    Posted 1 year ago #

    Hey I resolved the issue it looks like my pages were not set up correctly through my sql page. I uploaded a widget called search and replace and for all the files that linked to fremonthc.com//fhc or localhost/ fhc were all through my wamp server. So I checked all of the boxes and where it said search for I typed http://localhost and where it said replace with I typed http://fremonthc.com and hit go and it found 100+ files to change. Did the exact same thing when it was redirected to fremonthc.com//fhc just typed that in the search for and replace with http://fremonthc.com. Just a reminder to backup your database because you cannot do any changes. Thanks a load off my shoulders!!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.