WordPress.org

Ready to get started?Download WordPress

Forums

Help with validation errors? (2 posts)

  1. UNIQLOVE
    Member
    Posted 3 years ago #

    Trying to finish off my site, and have a bunch of errors when I validate it through http://validator.w3.org. Anyone willing to help me correct them? I've done a bunch on my own, but don't understand what the remaining ones even mean. Can you help step me through this as simple as possible? Any help GREATLY appreciated.
    http://www.UNIQLOVEblog.com
    {Validate by Direct Input - Source Below}
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

    <head>
    <script language="javascript" type="text/javascript">
    <!-- Begin
    loadImage7 = new Image();
    loadImage7.src = "http://uniqlove.com//sitebuildercontent/11/toptag5.2.gif";
    staticImage7 = new Image();
    staticImage7.src = "http://uniqlove.com//sitebuildercontent/11/toptag5.gif";

    // End -->
    </script>
    </head>

    <body>
    <img name="spacer" alt="Top Spacer" src="http://uniqlove.com//sitebuildercontent/11/topleft4.gif">


    <img name="image7" alt="UNIQLOVE tag" src="http://uniqlove.com//sitebuildercontent/11/toptag5.gif"

    <?php get_header(); ?>

    <div id="content-wrap">
    <div id="content">

    <div class="postarea">

    <?php if(have_posts()) : while(have_posts()) : the_post(); ?>
    <?php global $more; $more = 0; ?>

    <?php if ( in_category('gallery') && !is_single() ) continue; ?>

    <div <?php post_class(); ?>>

    <div class="posttitle">

    <div class="postdate">
    <div class="day"><?php the_time('d') ?></div>
    <div class="month"><?php the_time('M') ?></div>
    </div>

    <h5><?php the_category(' , '); ?></h5>
    <h2>" rel="bookmark"><?php the_title(); ?></h2>

    </div>

    <?php the_content('Read More'); ?>

    <div class="postmeta">
    <div class="postmeta_left">

    <p>#respond"><?php _e("Comment"); ?><img name="comment" alt="Comment" src="http://uniqlove.com//uniqloveblog/wp-content/themes/blissful_blog/images/comment.png"/>

    "><?php comments_number('Leave a Comment', '1 Comment', '% Comments'); ?></p>
    </div>
    <div class="postmeta_right">
    <p>

    &=<?php the_title(); ?>" target="blank">Share on Facebook
    <img name="tweet" alt="Tweet Article" src="http://uniqlove.com//uniqloveblog/wp-content/themes/blissful_blog/images/tinyfacebook2.png"/>

    - <?php
    $turl = getTinyUrl(get_permalink($post->ID));
    echo $turl;
    ?>" rel="nofollow" class="social-bookmark">Tweet Article

    <img name="tweet" alt="Tweet Article" src="http://uniqlove.com//uniqloveblog/wp-content/themes/blissful_blog/images/twitter.png"/>

    </p>

    </div>
    </div>

    </div>

    <?php endwhile; else: ?>
    <p><?php _e("Sorry, no posts matched your criteria."); ?></p>
    <?php endif; ?>

    <div id="pagenav">
    <div class="prev"><p><?php previous_posts_link(); ?></p></div>
    <div class="next"><p><?php next_posts_link(); ?></p></div>
    </div>

    </div>

    </div> <!-- #content -->

    <?php get_sidebar(); ?>

    </div>

    <div id="delimiter"></div>

    <?php get_footer(); ?>
    </body>

    </html>

  2. vtxyzzy
    Member
    Posted 3 years ago #

    I am not sure what you posted above, but if I go to http://www.UNIQLOVEblog.com and look at the source code, I see two instances of the DOCTYPE header. The first part may be from sitebuilder and the second from WordPress.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"

    That leads to all sorts of other errors.

Topic Closed

This topic has been closed to new replies.

About this Topic