WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Help with RSS (10 posts)

  1. Servant
    Member
    Posted 9 years ago #

    I'm completely new to the scene and have some questions that are probably no brainers for others out there. But I've spent several hours searching through this site, the Wiki documentation and various Google searches and am just getting more and more confused. It would be FANTASTIC if someone could clearly and plainly explain/document for us beginners the following:

    (1) What do I have to do to activate RSS2.0/Atom/Comments RSS2.0 for a WP 1.5 blog?

    (2) How do I test/make sure that RSS and/or Atom are working from my blog?

    When I click either the the RSS2.0 or Comments RSS2.0 links under "Meta" in the sidebar I get the message: "XML page cannot be displayed. Cannot view XML input using SXL style sheet...The following tags were not closed meta. Error processing resource 'http://logoswalk.com/journal/wp-rss2.php'."

    When I click the Atom 0.3 link I'm asked if I want to open the file.

    Any help would be very much appreciated and, if the answer's are obviously published somewhere that I've missed, I apologize in advance.

  2. dm87
    Member
    Posted 9 years ago #

    I am a newbie. About your second question, how to test to make sure the RSS feed is working. I think I know how to do that, in two ways. One is to visit the web page that displays the feed to make sure everything is OK. http://www.example.com/wordpress/wp-rss2.php

    The second way to test it is to try to read your feed in a program such as NewsNetWire. Subscribe to your own feed by adding a subscription, configuring it to use the same URL for your site as you see above.

    My site feed does not work. There are boxes that translate into tabs when I copy the html source code and paste it into a text editor. These are being generated automatically, and I wonder why.

  3. dm87
    Member
    Posted 9 years ago #

    Reading, reading, reading. I discovered elsewhere on the forum
    http://feedvalidator.org/
    which might help with testing rss.

    My site is getting a "Server returned HTTP Error 404:".

  4. Servant
    Member
    Posted 9 years ago #

    When I enter my blog (http://logoswalk.com/journal/wp-rss2.php) into Pluck, for instance, the error returned through feedvalidator is:

    Sorry, This feed does not validate.

    line 1, column 0: Undefined root element: meta

    <meta http-equiv="content-type" content="text/html;charset=iso-8859-1">

    line 2, column 0: XML parsing error: <unknown>:2:0: xml declaration not at start of external entity

    <?xml version="1.0" encoding="utf-8"?>

    Source: http://logoswalk.com/journal/wp-rss2.php
    1. <meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
    2. <?xml version="1.0" encoding="utf-8"?>

    What is it I need to correct in these above 2 lines?

  5. Marc
    Member
    Posted 9 years ago #

    Look in your dashboard, under "options" then "reading"

    make sure in the box labled "Encoding for pages and feeds:" has utf-8 entered.

  6. Servant
    Member
    Posted 9 years ago #

    Yes, it is utf-8.

  7. Servant
    Member
    Posted 9 years ago #

    Is it possible for somone to provide the first 2 lines from their WORKING wp-rss2.php file (WP v.1.5) so I could compare with mine? Maybe that will resolve the issue? (I'm a glass is half-full kind-a guy...) Mine are:

    <meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
    <?xml version="1.0" encoding="utf-8"?>

  8. Servant
    Member
    Posted 8 years ago #

    FOR THE RECORD: (In case future users search this forum.)

    Success for me! In another thread, macmanx provided the answer. By disabling my plug-ins it immediatly brought the RSS feeds online. I re-activated them 1 at a time and found a mis-behaving one which I re-downloaded, re-installed, and now everything's BE-YOO-TEE-FULL. The plug-inwas generating an unwanted first line in my rss feeds. Thanks for ending nearly 2 weeks of angst and groping, macmanx.

  9. paul
    Member
    Posted 8 years ago #

    Um, it would have been more helpful if you mentioned which plugin was causing the problem.

  10. Servant
    Member
    Posted 8 years ago #

    Sorry about that. It was "Subscribe Me" Beta 1.0. I downloaded it anew and reinstalled it and everything worked great! Thanks for following up.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags