WordPress.org

Ready to get started?Download WordPress

Forums

Help with Reverse Proxy and Permalinks (4 posts)

  1. akarus40
    Member
    Posted 1 year ago #

    Hello everyone,

    Ok, so before I begin, I've done some research on this topic and I know there has been some discussion about many solutions to fix this. But from my perspective(being a total Apache/PHP novice) I've really not seen a clear cut answer, hell maybe there isn't one. But so let explain what's going on and maybe some one can point me in the right direction.

    So I have a WP blog setup, its setup on a server like so:
    168.xxx.xxx.150/~username/en/blog

    We setup a reverse proxy to map it to: http://www.example.com/ext

    So the goal is to have it resolve to: http://www.example.com/ext/en/blog

    Again I admit my knowledge of Apache is minimal at best, so please be gentle. That being said, I was able to setup the <Virtual Host> directive in the httpd.conf file.

    So, the issue revolves around using Permalinks. If I don't use them, then everything seems to work fine, but when I try to enable them the site can't find any of the pages.

    I've read several articles on the WP site and others proposing alot of different solutions, some based around the <Virtual Host> directive, some based on .htaccess file and some on editing the wp-config.php file. I've tried them all and nothing seems to work for me.

    I guess I'm just confused on what I should actually be changing? Can anyone offer me any advise on what steps I should take to resolve this issue? Any help would be greatly appreciated.

  2. ricardusexa
    Member
    Posted 1 year ago #

  3. akarus40
    Member
    Posted 1 year ago #

    Ok, so I tried what was in the article you listed, but I'm getting a 404 error on the page.

    The article says I should replace my .htaccess file with this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Just wondering if anyone could maybe help point me in the right direction as to where that's failing?

  4. leonjh
    Member
    Posted 1 year ago #

    I spent quite an inordinately long time searching for a solution to the same problem: when running wordpress behind a proxy rewrite rule using anything other than the default permalink option would not work.

    Finally I came across this plugin:

    https://raw.github.com/mistermarco/wp_reverse_proxy/master/su_reverse_proxy.php

    Which, when added to the plugins folder and activated in admin, sorted the problem for me.

Topic Closed

This topic has been closed to new replies.

About this Topic