WordPress.org

Ready to get started?Download WordPress

Forums

Help with removing indented lists (11 posts)

  1. washy21
    Member
    Posted 7 years ago #

    Hi

    Can anyone help please. I've got a problem with the links in the wordpress site I have built. In MAC OSX it's fine but in Windows internet explorer it's not.

    The site is http://www.boltonartstudents.com you can see that the categories, pages, education links all seem to indent and I want them to sit flush left in line with the actual list of links.

    I've got limited CSS and PHP knowledge and I would be really grateful if someone can tell me exactly which files to edit. For instance, which file actually generates the HTML that contains the sidebar info.

    Help please

    John

  2. Root
    Member
    Posted 7 years ago #

    The default indent for ul, ol, li is different in each browser. You need to reset them in your CSS.

  3. washy21
    Member
    Posted 7 years ago #

    Thanks but it doesn't really help me fix it. Can anyone tell me how to fix the CSS then please.

  4. washy21
    Member
    Posted 7 years ago #

    Thanks but it doesn't really help me fix it. Can anyone tell me how to fix the CSS then please.

  5. Root
    Member
    Posted 7 years ago #

    Just set ul, ol {margin: 0}

    Adjust as necessary.

  6. rileycentral
    Member
    Posted 6 years ago #

    I found this in a search. If anybody picks it up I'd sure appreciate it!

    I'm using Sandbox Skin on my blog: Scrappr. Looked for the designers contact and not surprisingly couldn't get it.

    Seemingly simple issue here:

    My ol, ul WordPress calls are giving no indent in this theme.

    The blockquote works just fine however.

    I've tried a few changes to the css. Most recently as suggested by Root in this thread:

    .entry-content ul, ol {margin: 0}

    It didn't remedy the issue. I may have put it in the wrong area of the css? Anyway . . . if somebody could make a few suggestions of something it would help me out a lot. Here's a post on my blog that shows the issue:

    http://rileycentral.net/wordpress/?p=814

    Thanks in advance. I hope I don't reveal too much my greenness at CSS.

    Damien

  7. Adam Brown
    Member
    Posted 6 years ago #

    Setting margin:0 is what you do to get RID of the indent. Set it to something else. e.g. {margin:0 0 0 3em;}

    (the numbers are the top, right, bottom, left margins; you want to change the left one)

  8. rileycentral
    Member
    Posted 6 years ago #

    Hi adam. Thanks, that did the trick.

  9. rileycentral
    Member
    Posted 6 years ago #

    ack! Somehow I missed it again. Can anyone tell me how to indent ordered lists in this theme (Scrappr).

  10. rileycentral
    Member
    Posted 6 years ago #

    sorry, link was dead last time, fixed it: Here goes second try:

    "ack! Somehow I messed the css up again. Can anyone tell me how to indent ordered lists in"

    this theme

  11. rileycentral
    Member
    Posted 6 years ago #

    Ok, I fixed it again! This time I'm putting the snippet here in case I need it :)

    /* =typography
    =================================*/
    body {
    	font-family: georgia, serif;
    }
    h1,h2,h3,h4,h5,h6,#blog-description,#menu li a,.published,.sidebar a,.comments-link,.comment-author, .category-quote .entry-content blockquote, .category-quote .entry-content blockquote p{
    	font-style:italic;
    	font-weight:bold;
    }
    
    .entry-content ol {margin:0 0 0 3em;}

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.