WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Help with noindex,follow on Category Pages (6 posts)

  1. cnymike
    Member
    Posted 5 years ago #

    I had recently converted my static html site to wordpress and was initially elated with the end result. When making the conversion to WordPress, I decided to list each individual business as a Post and assign each business (post) to a Category (ie: Photographers, Caterers, etc). However within in a couple of weeks, all my previously high ranking pages essentially disappeared from Google. It was just in the last day or two that I finally realized why. My Category pages, on which I based my site, were carrying the meta-tag, “noindex, follow”. HOLY CRAP. Now I know why Google dropped my site.

    So now I’ve got a huge problem with my site and am not sure how to deal with it especially when considering the duplicate content issue.

    How do I fix this? Should I change my category pages to “index,follow” and make individual posts “noindex, follow” ? I think in the case of my directory site, it’s more important that the category page be indexed rather than the individual posts.

    Sure could use some help from the real experts.

  2. iridiax
    Member
    Posted 5 years ago #

    I would have both posts and category archives as index, follow and only worry later about fixing duplicate content issues if you experience them (some sites never do). Is the noindex, follow from your theme or from a SEO plugin?

  3. cnymike
    Member
    Posted 5 years ago #

    >>Is the noindex, follow from your theme or from a SEO plugin? <<

    It must be from the theme because the only SEO plugin I use is Headspace and I don't believe Headspace offers any options for modifying the follow/nofollow, index/noindex parameters.

    I'm not really sure what theme file would be controlling this either. For what it's worth, I'm using the Flexx theme by iThemes for my site.

  4. cnymike
    Member
    Posted 5 years ago #

    I found the troublesome code in the functions.php file in the theme.

    //add the follow code to our meta section
    	echo "\n".'<!--To follow, or not to follow-->'."\n";
    	if(is_home() || is_single() || is_page()) echo '<meta name="robots" content="index,follow" />'."\n";
    	elseif($wp_theme_options['cat_index'] != 'no' &amp;&amp; is_category()) echo '<meta name="robots" content="index,follow" />'."\n";
    	elseif(!is_home() &amp;&amp; !is_single() &amp;&amp; !is_page()) echo '<meta name="robots" content="noindex,follow" />'."\n";

    But is it as simple as just changing the "noindex,follow" to "index,follow" ?

  5. iridiax
    Member
    Posted 5 years ago #

    Yes, or check the theme configuration/options page for your theme. It looks like you have the option to enable or disable category indexing.

  6. cnymike
    Member
    Posted 5 years ago #

    @iridiax: Thanks for your observation. I dug around the theme settings and sure enough there was the option to change the category setting. Appreciate the help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.