WordPress.org

Ready to get started?Download WordPress

Forums

Help with Multiple Installations IIS7 -Prety Permalinks Not Working on same host (1 post)

  1. macs
    Member
    Posted 1 year ago #

    Hi there everyone,

    This is my first time asking for help around here, i have searched all over the internet and around here but i couldn't find nothing clear and tried everything but still unable to fix.

    I need urgent help to fix WordPress permalink structure on my Windows shared host with IIS7 where i have re-installed 3 WordPress installations after moving my domains from another account according to this scenario and it's the only one that is working for my sites:

    The ROOT folder with the following web.config :

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
      <system.webServer>
        <rewrite>
          <rules>
    	  <rule name="SITEB.com" stopProcessing="true">
                <match url=".*" />
                <conditions>
                    <add input="{HTTP_HOST}" pattern="^(www.)?SITEB.com" />
                    <add input="{PATH_INFO}" pattern="^/SITEB/" negate="true" />
                </conditions>
                <action type="Rewrite" url="\SITEB\{R:0}" />
            </rule>
    	  <rule name="SITEC.com" stopProcessing="true">
                <match url=".*" />
                <conditions>
                    <add input="{HTTP_HOST}" pattern="^(www.)?SITEC.com" />
                    <add input="{PATH_INFO}" pattern="^/SITEC/" negate="true" />
                </conditions>
                <action type="Rewrite" url="\SITEC\{R:0}" />
            </rule>
    	<rule name="wordpress" patternSyntax="Wildcard">
    					<match url="*"/>
    						<conditions>
    							<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true"/>
    							<add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true"/>
    						</conditions>
    					<action type="Rewrite" url="index.php"/>
    				</rule>
    		</rules>
        </rewrite>
      </system.webServer>
    </configuration>

    NOW, as you may see on the above rules, i'm redirecting SITEB.com and SITEC.com to its folders.

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
      <system.webServer>
        <!-- Set the default document -->
        <defaultDocument>
          <files>
            <remove value="index.php" />
            <add value="index.php" />
          </files>
        </defaultDocument>
    	<directoryBrowse enabled="false" />
      </system.webServer>
    </configuration>

    Here is the same web.config from both SITEB.com and SITEC.com that are installed in separate folders in root, and the only one that works with those two independent WordPress installations on default permalink structure.

    I need urgent help to fix and use pretty permalinks as /%category%/%post_name%/ to keep my pages in search and rank. If i chose that structure inside any SITEB or SITEC site, the servers give me a 500 error.

    Please someone help, Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic