WordPress.org

Ready to get started?Download WordPress

Forums

Help with installation on GoDaddy (3 posts)

  1. HungryWolf
    Member
    Posted 6 years ago #

    I'm sorry if this has been posted a thousand times, which I'm sure it has, but I really need help figuring this out, and the search results that I have found aren't helping at all.

    My hosting is with godaddy.com, and I currently have Windows Economy Hosting. I have followed the directions for installing WordPress, but no matter what I do, I cannot get it to install. I set up a MySQL, with the database called rbrenner, and I have put in the right information to the wp-config.php file, but when I try to go to my website to install it, I get this message: Your PHP installation appears to be missing the MySQL which is required for WordPress.

    It's driving me crazy.

    Here is what is currently in my wp-config.php file:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'rbrenner'); // The name of the database
    define('DB_USER', 'rbrenner'); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxx'); // ...and password
    define('DB_HOST', 'p41mysql73.secureserver.net'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    Is there something that I might be missing? Something I could have incorrectly put in? I know those details are correct. I know the database, username, and password are correct, and I'm pretty sure the host is correct as well.

    Thanks in advance.

  2. HungryWolf
    Member
    Posted 6 years ago #

    Alright, I get the gist of what I am doing wrong. I believe it is due to my operating system being Windows, and something with PHP not being enabled.

    I've looked over and over and I do not see how to enable PHP. I believe I have seen that I can enable it with my Windows hosting, but I can't figure it out. Is there a way I can easily do this, without having to switch to Linux?

  3. homeycomb
    Member
    Posted 6 years ago #

    Is there a way I can easily do this, without having to switch to Linux?

    thats a question for the people at your hosting company.

Topic Closed

This topic has been closed to new replies.

About this Topic