WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Help with hatch theme headings for posts on home page (6 posts)

  1. wotnow
    Member
    Posted 1 year ago #

    Hi site here http://efflorescemakeup.com.au/

    On the home page the images are fed by the featured image of the posts. When I hover over the images I get the titles of the posts but for the life of me I cant get them to appear without hovering. I have tried every css trick except the one that works. I know they have a class of entry-title.

    Appreciate any help with this, driving me nuts

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    That was a bit tricky -- took me a while to figure it out too. It looks like it's actually controlled by the opacity in this CSS:

    .home .hentry .entry-title, .archive .hentry .entry-title {
        background: none repeat scroll 0 0 #FFFFFF;
        bottom: 0;
        font-weight: normal;
        margin-bottom: 0;
        max-width: 90%;
        opacity: 0;
        position: absolute;
        right: 0;
    }

    If you change the opacity to 1 -- they appear constant (not just upon hover).

  3. wotnow
    Member
    Posted 1 year ago #

    Thank you so much, I never would have found that! The only problem is that I now have white boxes over the featured images.

    http://i605.photobucket.com/albums/tt133/WhatNowThe2nd/Forums/ScreenShot2012-10-18at64609AM.png

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    In your child style.css, try adding this:

    h2.entry-title {
      opacity: 1;
    }
  5. wotnow
    Member
    Posted 1 year ago #

    No that made no difference, but thanks for trying

    I tried this as well

    h2.entry-title a{
    opacity: 1;
    }

  6. wotnow
    Member
    Posted 1 year ago #

    Actually that did work, thanks. There was some code higher up that was over-riding it.

Topic Closed

This topic has been closed to new replies.

About this Topic