WordPress.org

Ready to get started?Download WordPress

Forums

Help with getting my permalinks working (6 posts)

  1. o3world
    Member
    Posted 4 years ago #

    I'm having some issues getting permalinks working correctly. The site is set up so the front page displays a static page, currently the "Home" page (home.php, template name "home"). I have numerous other pages set up as well as a blog (blog.php, template name "blog"). As long as I have my permalinks set to "default" (ugly) everything works fine. As soon as I give them ANY kind of custom structure I get nothing but 404s.

    I've read everything about Making Your Blog Appear in a Non-Root Folder as well as everything here on permalinks. I've done some searching around as well but thus far am not coming up with anything helpful.

    I'm running WordPress 2.8.5, which I manually upgraded to from an old 2.0.4 installation. Not sure if that would cause issues or not but it's probably good to note. Currently I'm running all this locally but I should have a dev site set up soon, when I do I'll provide a link.

    This is my first go at developing a WordPress site so if I'm leaving out some important details I apologize, just let me know if anyone needs any more info on my situation or has some thoughts/ideas for solutions. Thanks all!

  2. iridiax
    Member
    Posted 4 years ago #

    Currently I'm running all this locally

    This is likely the issue as you have to take special steps to make them work, see: http://codex.wordpress.org/Installing_WordPress#Installing_WordPress_on_your_own_Computer

    Also try a forum search for permalinks and whatever you are using on your home server.

  3. o3world
    Member
    Posted 4 years ago #

    Ahh, Thanks for the tip. I'm gonna try moving it to a DEV environment and see if that fixes it.

  4. o3world
    Member
    Posted 4 years ago #

    I moved the site to a staging server and I'm still having issues with my permalinks not working. Again in the "default" setting everything works fine. As soon as I change it to any kind of custom settings I get a 500 Internal Server Error on every page (home page, admin, blog, whatever).

    .htaccess with default settings
    # BEGIN WordPress

    # END WordPress

    .htaccess with /%year%/%monthnum%/%postname%/ settings
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Any tips? I've been searching through the forums here but have yet to come up with any solid leads as to how to fix this.

  5. maxemil
    Member
    Posted 4 years ago #

    did you verify rewrite is allowed on the server http.conf settings?

    http://www.codestyle.org/sitemanager/apache/errors-500.shtml

    BR\ME

  6. o3world
    Member
    Posted 4 years ago #

    Looking into that right now. I'm assuming it's not turned on because:

    A) I'm on a shared environment.
    B) Simply turning the RewriteEngine On in .htaccess breaks the site.

Topic Closed

This topic has been closed to new replies.

About this Topic