WordPress.org

Ready to get started?Download WordPress

Forums

Custom Upload Dir
Help with Custom Upload Dir Not Working (5 posts)

  1. thalead
    Member
    Posted 3 years ago #

    Hello,

    For some odd reason I cannot seem to get the custom upload directory to work. The base directory works fine. For instance, I use the following as the base directory:

    wp-content/newmedia

    I use the following as the custom upload directory:

    /%post_author%

    When I view the path for a media file, I only see the base directory being used, not the custom upload directory. I've also tried some of the other available placeholders but nothing seems to work. The path is always

    wp-content/newmedia

    Thanks in advance for any insight anyone can provide.

  2. ulfben
    Member
    Plugin Author

    Posted 3 years ago #

    The Custom Upload Dir currently only applies custom path's to files that are uploaded (attached) to posts. When I wrote it I wasn't aware there even was a stand-alone media upload thingy. :)

    It's on my todolist to have this fixed, obviously. For now; make sure you save your drafts or publish the post before uploading files to it. This ensures all data (dates, post author, categories etc) is available for the plugin to use.

    Also be aware that Custom Upload Dir does not move your previously uploaded files. It only deals with new uploads.

  3. ulfben
    Member
    Plugin Author

    Posted 3 years ago #

    I just realized there's been a long-standing bug on my todolist with the author name. :)

    I've committed 3.0.2 now; it fixes %post_author% and timestamps for files uploaded without a post.

    Please try it out and let me know if there's problems.

  4. thalead
    Member
    Posted 3 years ago #

    Thanks for the quick update. It appears to be working now!

    Definitely looking forward to the updated functionality for the stand-alone media library. Thanks for all your hard work.

  5. mehedi
    Member
    Posted 3 years ago #

    Still not working with %ID% & %post_author% for WordPress 3.2.1 Will you check and fix this?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic