WordPress.org

Ready to get started?Download WordPress

Forums

Tried to Move WordPress, Site Broken (4 posts)

  1. mcography
    Member
    Posted 1 year ago #

    I seem to have completely screwed up my site, and I'm kind of freaking out. Here's a rundown of what I did.

    1. I had a site running at mydomain.com, but I wanted to rebuild it. So I downloaded a new installation of WordPress at mydomain.com/test and built a new theme.
    2. I finished the new theme and was ready to move it to mydomain.com. I decided to leave everything in the subdomain for the move, so I followed these instructions.
    4. It worked fine. Mydomain.com was displaying the new site.
    5. Then, I stupidly decided that I wanted to rename the subdirectory from /test to /v2 (because I wanted a cleaner name and I wanted to leave /test open for testing rather than use it for my new site).
    6. Everything broke.
    7. I tried to change the subdirectory back to /test because the site was working with that, but everything is still broken. The theme doesn't seem to be loading. My site is not displaying any styles. My media is gone. My plugins are gone.

    Is there any way to fix this? I've been working on this redesign for ages, and I'm desperate. Please, please help.

    This is my site.

    [No bumping - especially after just 1 hour! If it's that urgent, consider hiring someone.]

  2. Peter
    Member
    Posted 1 year ago #

    You seem to be calling the theme from /test/assets/ is that right?

    Or should it be /wp-content/THEMENAME/ ??

    If you've corrupted all the entries in your database you'll want to run some SEARCH and replace SQL .

  3. mcography
    Member
    Posted 1 year ago #

    You're right. It should be /wp-content/THEMENAME/. Where do I change this?

  4. mcography
    Member
    Posted 1 year ago #

    Also, now I'm getting an error that says my .htaccess is not writable. Do you know how I can fix that?

Topic Closed

This topic has been closed to new replies.

About this Topic