WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[resolved] Help! The SexyBookmarks update just took down my whole blog and my dashboard (14 posts)

  1. CelluloidBlonde
    Member
    Posted 3 years ago #

    Okay I just did the sexybookmark update which is supposed to be compatible with WordPress 3.1 and the whole blog is down including my control panel I need a way to fix this immeiately.

    The message I am getting when I try to access the dashboard is

    [code]

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/content/98/6009398/html/wordpress/wp-content/plugins/sexybookmarks/includes/shr_pub_pro.php on line 4

    [/code]

  2. CelluloidBlonde
    Member
    Posted 3 years ago #

    PS: You can also see this in action if you try to view the blog, which is down at http://newacademy.us/wordpress

    This is so messed up, I just worked my tail up to open this on March 1 and have just been building traffic, I'm going to lose all credibility with new visitors now. Sigh. I know better than to trust updates without backing up :::headdesk:::

  3. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    FTP into your site (or use whatever file management application your host provides) and delete the wordpress/wp-content/plugins/sexybookmarks folder.

  4. CelluloidBlonde
    Member
    Posted 3 years ago #

    Also if seeing the code on the php page that is saying it is the problem there will help -- I'm not good enough at php to figure out how to fix this on my own and also don't trust any of the other pages right now either -- this is the page code where does this need to be rewritten?:

    [Code moderated as per the Forum Rules. Please use the pastebin]

  5. CelluloidBlonde
    Member
    Posted 3 years ago #

    Thank you Esmi.

  6. CelluloidBlonde
    Member
    Posted 3 years ago #

    (The blog is back up and running, yay! -- bummer about sexybookmarks, sexybookmarks were really cute but I'm afraid to use them again. Urk.)

  7. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    CelluloidBlonde, sorry about the trouble!! we suspect you're using an old version of PHP (v4) which caused this. Who is your web host?

  8. CelluloidBlonde
    Member
    Posted 3 years ago #

    Hi, thanks for the response. I'm using GoDaddy servers and the php is 4 -- you might want to post a note on that update that the update requires php5 -- if I'd known I would have known not to update.

    The older version of sexybookmarks worked fine, but I don't know where to find the older version I installed three days ago to reinstall so I had to dump the file and picked up damnsexybookmarks as a replacement. If you've got the version that's compatible with 3.1 using php4 I can reinstall your program.

  9. Knut Sparhell
    Member
    Posted 3 years ago #

    @CelluloidBlonde: GoDaddy says:

    All of our Linux hosting accounts can support PHP 5.2.14. Older accounts that had PHP 4 enabled support 4.3.11 but can be upgraded to PHP 5 at any time. For more information, see Viewing or Changing Your PHP Language Version.

    If you do not switch to PHP 5 you will not be able to run WordPress 3.2 (next major version).

  10. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    Some hosting providers are still using php 4 as their default for scripts, but offer php5 as well. To force your scripts to all use php5, you can try adding this to a .htaccess file on your site:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    We're about to release a new version of SB that will work with PHP4. It should be available in 2-3 hours.

  11. CelluloidBlonde
    Member
    Posted 3 years ago #

    Knut, thanks for the info. I worry about forcing up to ph5 I've got forum classrooms and workshops running on those servers -- of course that needs to upgrade too. Urk. I'm pretty sure the masks are going to fall off it the second I upgrade it. :::headdesk:::

    Shareholic, excellent, I will go with the version that will work with php4, for now.

    Thanks again for the responses and help. What version number should I be watching for for the php4 compatible upgrade of sexybookmarks?

  12. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    @CelluloidBlonde we just released an update that *should* fix PHP4 issues. SB v3.3.5. Can you please give it a try? thanks!!

  13. CelluloidBlonde
    Member
    Posted 3 years ago #

    Hi Share. Sorry, had to be on set and then review an overload of student material could not get to this till tonight. I installed the new version just now and it is working. Yay! No crashed blog!

    Thank you so much for your helpful response and for updating the new version so it works with php4.

    [Hi Knut, I see you glaring -- there are really fun warnings about not being updated to php5 -- promise to upgrade soon just can't plan for downtime right now if things blow up with the upgrade that forum has to stay operative. Will try to hit this in about 8 weeks when the forum is quieter.]

  14. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    Glad it is working now!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic