WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] HELP! Template is gone from blog! (11 posts)

  1. momunplugged
    Member
    Posted 6 years ago #

    I was messing around with the options page changing the WP address and Blog address because my domain name (www.unplugyourkids.com) was directing to my index page, not my blog.

    Now I think I have changed it back to what it was before (my ISP+account+"/blog") but http://www.unplugyourkids.com still directs to my index and if I click the "blog" subdirectory, the information is there but the template is gone.

    What's wrong? Thanks!

    http://www.unplugyourkids.com/blog/

  2. whooami
    Member
    Posted 6 years ago #

    whats wrong is that you cant change those settings arbitrarily - they actually mean something.

    Look at the source of the page you linked to:

    What do you see?

    <link rel="stylesheet" type="text/css" href="http://www.unplugyourkids.com/wp-content/themes/wp-andreas01-12/style.css" />

    There is the path to your stylesheet.

    Youve messed with those options and now theyre pointing to the wrong place.

  3. MichaelH
    Member
    Posted 6 years ago #

    If you want visitor to see your blog just at http://www.unplugyourkids.com/blog then both your WordPress address (URL) and Blog address (URL) should be set to http://www.unplugyourkids.com/blog

    If you want vistors to see your blog at http://www.unplugyourkids.com then your WordPress address (URL) should be http://www.unplugyourkids.com/blog and your Blog address (URL) should be http://www.unplugyourkids.com and this index.php file should be in your web-root folder:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./blog/wp-blog-header.php');
    ?>

    That last setup is described at: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    If you can't login to change your Options then this will help:
    http://www.tamba2.org.uk/wordpress/site-url/

  4. momunplugged
    Member
    Posted 6 years ago #

    MichaelH-

    I copied the index.php file into my root directory (public_html) and made the change as explained by you and the codex.

    I now have the following settings:

    WP-URL: http://www.unplugyourkids.com/blog
    Blog URL: http://www.unplugyourkids.com

    That caused some progress since http://www.unplugyourkids.com now goes to my blog, but there is still no stylesheet.

    Also, the codex said to log in the new way, which I think should be: http://unplugyourkids.com/blog/wp-admin/, but I get an "Error 404 Page Not Found."

    (All the WP files were already in their own subdirectory entitled "blog")

  5. momunplugged
    Member
    Posted 6 years ago #

    Whooami-

    Yeah, I know. It is dumb to mess with what you don't understand, but I thought I was helping things!

    I see now that the stylesheet path is wrong. The WP folders are all in the subdirectory "blog." Should I change the path? But why wouldn't unplugyourkids.com/blog/wp-admin take me to the admin page since the admin files are indeed in the subdirectory "blog?"

    As you can see, I know just enough to mess things up!

  6. MichaelH
    Member
    Posted 6 years ago #

    http://unplugyourkids.com/blog/wp-login.php is your login URL

    If you can login, change to the WordPress Default Theme to see if you get a working blog.

  7. momunplugged
    Member
    Posted 6 years ago #

    Michael,

    I logged in but it took me to the "Error 404 page not found" page. Also, the login screen looks weird and is without anykind of template or formatting either.

    Also-I had to use Username "admin" and the password that was sent to me from WP. It wouldn't take my usual username and pass.

  8. momunplugged
    Member
    Posted 6 years ago #

    OK-it let me log in when I did it the old way:

    http://74.52.60.18/~marybun/blog/wp-login.php

    All is still without any kind of color or theme, but at least I am at the control panel.

  9. momunplugged
    Member
    Posted 6 years ago #

    I tried to change to the Default Theme and it said I did, but there is still no theme on the blog.

  10. momunplugged
    Member
    Posted 6 years ago #

    HOORAY! It's back!

    When I checked the options page, I thought I had put http://www.unplugyourkids.com/blog for the WP-URL, but I actually had http://www.unplugyourkids.com for both URLs. When I changed the WP-URL to the correct one, I had to log in again then everything went back to normal.

    Thanks so much for the help! I really appreciate your time!

  11. andyrouse
    Member
    Posted 5 years ago #

    Hi - I'm having a similar problem to momunplugged, but I get to my login screen, and it then redirects me to what it thinks is the new location of the blog.

    In effect - I can't get to my configuration screen anymore. Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic