WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Help putting in the flash player version detection code in the write place?! (1 post)

  1. jamesb4551
    Member
    Posted 5 years ago #

    Could someone please tell me where to put the detection code for flash, i use alot on the site and it only works best in version 9 so need to detect that. so far i have this, but where does it go? in the header.php?

    <!--<head>-->
    <!-- I'm assuming I definately put this in the header.php -->
    <script language="javascript"> DetectFlashVer = 0; </script>
    <script language="JavaScript" type="text/javascript">
    <!--
    // -----------------------------------------------------------------------------
    // Globals
    // Major version of Flash required
    var requiredMajorVersion = 9;
    // Minor version of Flash required
    var requiredMinorVersion = 0;
    // Revision of Flash required
    var requiredRevision = 45;
    // -----------------------------------------------------------------------------
    // -->
    </script>
    <!--</head> so is that all that goes into the header.php-->

    <body> <!-- would this be best put in the page.php or in the header.php -->
    <script language="JavaScript" type="text/javascript">
    <!--
    if (AC_FL_RunContent == 0 || DetectFlashVer == 0) {
    alert("This page requires AC_RunActiveContent.js.");
    } else {
    var hasRightVersion = DetectFlashVer(requiredMajorVersion, requiredMinorVersion, requiredRevision);
    if(hasRightVersion) { // if a correct/acceptable version of flash is detected it should be ok to
    // leave this with no code inside yeah?

    // or do I need to have any code in here?

    } else { // for flash being too old or can't detect the plugin
    var alternateContent = 'Sorry you need to get with it!'
    + 'This content requires the Adobe Flash Player.'
    + '(hrefhere)=http://www.macromedia.com/go/getflash/>Get Flash(enda)';
    document.write(alternateContent); // insert non-flash content
    }
    }
    // -->
    </script>
    <noscript>
    // Provide alternate content for browsers that do not support scripting
    // or for those that have scripting disabled.
    Front Army website uses the flash player to watch all the lovely girls and all the cool shit we find, so if you don't have it your missin out. Go download the Adobe Flash Player version 9 and everything will work out just fine.
    (hrefhere)"http://www.macromedia.com/go/getflash/">Get Flash(enda)
    </noscript>

Topic Closed

This topic has been closed to new replies.

About this Topic