WordPress.org

Ready to get started?Download WordPress

Forums

HELP!!! (problem after site move) (9 posts)

  1. amits
    Member
    Posted 8 years ago #

    Hi All,

    I basically moved my blog from url and hosting account to another and in terms of the db I used phpmyadmin and just did and export and then and import.

    however what's happening now is that when I go to site admin and click on any of the options it's trying to connect to my old url.

    What do I need to change so that from now on it all points to the correct url?

    if I try and changed the url information in general options I keep getting the following message:

    "Sorry, you need to enable sending referrers for this feature to work". When I click on that link it takes me to http://codex.wordpress.org/Enable_Sending_Referrers

    But i just don't quite understand what to do.

    Your help is greatly appreciated!!

    Amit

  2. moshu
    Member
    Posted 8 years ago #

    If you didn't do it before the move, try to change the site_url and home values in the options table in the DB. See this tutorial:
    http://www.tamba2.org.uk/wordpress/site-url/

  3. amits
    Member
    Posted 8 years ago #

    Cheers moshu! I will try that and get back to you!!

    :-)))

  4. amits
    Member
    Posted 8 years ago #

    Moshu, that worked brilliantly...thanks for the link!! :)))

    Amit

  5. amits
    Member
    Posted 8 years ago #

    Hey Moshu,

    I've hit a snag...i followed the instructions on that page...including the point that's mentioned about deleting everything in the cache folder, however, now I cannot click on any of the old blogs....i just get a page not found error. I made a backup of everything in my cache directory and as soon as I put it back is just points to the old URL...anyway I can get around this???

    Thanks

  6. amits
    Member
    Posted 8 years ago #

    Hey Moshu,

    I've hit a snag...i followed the instructions on that page...including the point that's mentioned about deleting everything in the cache folder, however, now I cannot click on any of the old blogs....i just get a page not found error. I made a backup of everything in my cache directory and as soon as I put it back is just points to the old URL...anyway I can get around this???

    Thanks

  7. mylagoon
    Member
    Posted 8 years ago #

    Looks like the problem is with your .htaccess file. This means the permalinks setting you want have to be regenerated as they are still from the old site.

    Try going to the permalink page in WP Admin and regenerating the permalinks. (you may want to try turning them off by setting it to default (ie. siteurl.com/?p=12), and then back on again)

    If that doesn't work, delete your .htaccess file and try generating your permalinks from scratch.

  8. moshu
    Member
    Posted 8 years ago #

    Did the permalinks ever worked on this new place/host/server?
    Did you update your permalink options after the move?
    Did you update the .htaccess file?

    Edit. I type slowly...

  9. amits
    Member
    Posted 8 years ago #

    LOL @ Moshu

    Urrrrrrrrm I've gotta be honest, i'm new to this whole web thing not to mention totally new at blogging. well anyway just so you guys now, I started again.

    I followed all the steps on this page - http://www.tamba2.org.uk/wordpress/move/ just now and I've managed to get it all working now.

    dang this is hard work! :)

    Thanks again for all your help, no doubt I will be back with another problem soon! :p

    Thanks

    Amit

Topic Closed

This topic has been closed to new replies.

About this Topic