WordPress.org

Ready to get started?Download WordPress

Forums

HELP Please: FastCGI Error : aborted: error parsing headers: malformed header (9 posts)

  1. fas.khan
    Member
    Posted 5 years ago #

    Hello all,

    I am in a quite a drastic situation as my fully functional and operational site is filling up my error logs with the following error:-

    [Tue Jun 23 15:29:41 2009] [error] [client 66.666.66.66] FastCGI: comm with server "/home/httpd/vhosts/default/fcgi-bin/php5fcgi" aborted: error parsing headers: malformed header 'HTTP/1.1 404 Not Found'

    Every page of my wordpress, be it my admin page or a normal site mode is generating this error in the logs. What happens is that this error keeps on coming and a time comes that this error shuts down the site and the site starts giving me Internal Server 500 Error. Then, everytime, I have to do some temporary workaround.

    My Site has lot of data and it is now at a stage where there is no rolling back. I am in a big trouble, please help me in this situation.

    Again, this error is being generated when any page of WP is assessed.

    This is my site.

    http://www.ewp.eu

    Many Thanks.

  2. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    Check here, http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fwww.ewp.eu%2f

    you have some net-enabling start tags not followed by an end tag. Maybe that is doing it.

  3. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    You are on a Window server? That is most likely the problem.
    Google wp fast cgi error - there is help there.

  4. fas.khan
    Member
    Posted 5 years ago #

    I am on Linux Server :(

    any other suggestion please.

    I am very thankful for your help.

  5. bh_WP_fan
    Member
    Posted 5 years ago #

    Fixing the validation errors is still something which should be looked into.

    Here are the headers your site returns:

    HTTP/1.1 302 Moved Temporarily
    Date: Wed, 24 Jun 2009 14:13:09 GMT
    Server: Apache
    Set-Cookie: wassup=YmU2NGRiNDQzMTgyNWRiNzE1YTNhOTc2MmE0NzdkNmY6OjEyNDU4NTU0OTE6Ojo6NjYuMTQ3LjI0My4xMTU6Om9mZmljZTIuYmx1ZWhvc3QuY29t; expires=Wed, 24-Jun-2009 15:03:11 GMT; path=/
    X-Pingback: http://www.ewp.eu/xmlrpc.php
    Location: http://www.ewp.eu/
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8

    As far as I can tell there aren't any noticeable problems in there unless there's a problem with your cookie.

    Try disabling FastCGI all together. It may just be that your site/theme/plugin-being used in your site, won't work with it.

    Remove all lines in regards to fcgi or fastphp from your .htaccess (Or comment them out with a # at the beginning of the line) and put in a line which looks like this:

    AddType application/x-httpd-php5 .php

    OR this:

    AddHandler application/x-httpd-php5 .php

    Edit: Cross-referencing duplicate post here: http://wordpress.org/support/topic/281273?replies=5

  6. fas.khan
    Member
    Posted 5 years ago #

    Hi,

    Thank you very much for your reply ...

    I removed those lines as per your suggestion in the htaccess file, but still in vain!

    I will now fix the validation errors and will let you know here about it too.

    Many Thanks!

  7. fas.khan
    Member
    Posted 5 years ago #

    I also removed those errors "net-enabling" validation ones ... and it is still there :(

    I am so ****ed! :(

  8. bh_WP_fan
    Member
    Posted 5 years ago #

    re-upload the wordpress files as if you were upgrading it. When doing this, keep your plugins folder renamed to something else, and switch your theme to the default theme.
    This problem is generally caused by cgi/perl problems.
    Again, disable fastcgi. It might just make all of your problems go away. If you are still getting fastcgi errors, then it isn't disabled. Contact your host to help you with it if you need to.

  9. fas.khan
    Member
    Posted 5 years ago #

    Thanks Bh,

    I will try this out and will let you know.

    Thank you very much for hanging in.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags